summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2020-09-02 12:21:44 +0200
committerJulian Xhokaxhiu2020-09-02 12:21:44 +0200
commit708995476866898ea3566854b45131a9f81b4aff (patch)
tree9eb10d8dfb5f5c4577cac879f02e36ffe7df7b8a
downloadaur-708995476866898ea3566854b45131a9f81b4aff.tar.gz
0.1.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD31
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..726abb5d4538
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = asroute
+ pkgdesc = Interpret traceroute output to show names of ASN traversed
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/stevenpack/asroute
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ source = git+https://github.com/stevenpack/asroute
+ sha256sums = SKIP
+
+pkgname = asroute
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31b3675bb091
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# ...but
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..668d29ab4486
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Julian Xhokaxhiu <info at julianxhokaxhiu dot com>
+pkgname=asroute
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Interpret traceroute output to show names of ASN traversed"
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/stevenpack/asroute"
+license=('MIT')
+makedepends=(
+ 'cargo'
+)
+source=(
+ "git+https://github.com/stevenpack/asroute"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+prepare() {
+ cd "${srcdir}/asroute"
+ git checkout v${pkgver}
+ git submodule update --init --recursive
+}
+
+package() {
+ cd "${srcdir}/asroute"
+
+ cargo build --release --verbose
+
+ install -Dm755 "target/release/asroute" "$pkgdir/usr/bin/asroute"
+}