summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2015-09-23 10:50:27 -0400
committerDrew DeVault2015-09-23 10:50:36 -0400
commitbcec4a10a82c73bbfc08cd0e93c6bda494578c8e (patch)
tree226a872e9c21545fca9574bee997d217609bd906
downloadaur-bcec4a10a82c73bbfc08cd0e93c6bda494578c8e.tar.gz
Initial commit (import from aur3)
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rwxr-xr-xAssimpNet.dll.config5
-rwxr-xr-xPKGBUILD36
-rwxr-xr-xassimp-net.pc.in9
5 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5649c1dc297b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = assimp-net
+ pkgdesc = A .NET wrapper for the Open Asset Import Library (Assimp).
+ pkgver = 3.3.1
+ pkgrel = 2
+ url = https://code.google.com/p/assimp-net
+ arch = any
+ license = MIT
+ makedepends = dos2unix
+ makedepends = subversion
+ makedepends = mono
+ depends = assimp
+ depends = opentk
+ source = assimp-net::svn+http://assimp-net.googlecode.com/svn/tags/3.3.1
+ source = assimp-net.pc.in
+ source = AssimpNet.dll.config
+ sha1sums = SKIP
+ sha1sums = 9d1ad601ca7e56327068840b10cab32da90cab04
+ sha1sums = bfd87bdfad2eeb99553b8e7ba4b2029cbbf11042
+
+pkgname = assimp-net
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c4c91139ae0a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+assimp-net/
diff --git a/AssimpNet.dll.config b/AssimpNet.dll.config
new file mode 100755
index 000000000000..2c4e7de0eb11
--- /dev/null
+++ b/AssimpNet.dll.config
@@ -0,0 +1,5 @@
+<configuration>
+<dllmap os="macos" dll="assimp.dll" target="libassimp.dylib"/>
+<dllmap os="linux" dll="assimp.dll" target="libassimp.so"/>
+</configuration>
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..0eefeaa64e3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=assimp-net
+pkgdesc="A .NET wrapper for the Open Asset Import Library (Assimp)."
+pkgver=3.3.1
+pkgrel=2
+arch=(any)
+license=("MIT")
+url="https://code.google.com/p/assimp-net"
+source=("$pkgname::svn+http://assimp-net.googlecode.com/svn/tags/$pkgver"
+"assimp-net.pc.in"
+"AssimpNet.dll.config")
+depends=(assimp opentk)
+makedepends=(dos2unix subversion mono)
+sha1sums=('SKIP'
+ '9d1ad601ca7e56327068840b10cab32da90cab04'
+ 'bfd87bdfad2eeb99553b8e7ba4b2029cbbf11042')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ find . -type f -exec dos2unix {} \;
+ sed -i -e "s,Assimp32.so,libassimp.so,g" -e "s,Assimp64.so,libassimp.so,g" AssimpNet/Unmanaged/AssimpLibrary.cs
+}
+
+build() {
+ cd "${srcdir}/$pkgname"
+ xbuild AssimpNet.sln /p:Configuration=Net45-Debug
+}
+
+package() {
+ cd "${srcdir}/$pkgname/AssimpNet/bin/Net45-Debug"
+ install -Dm644 "AssimpLicense.txt" "$pkgdir/usr/share/licenses/$pkgname/AssimpLicense.txt"
+ find . -name 'AssimpNet.dll*' -exec install -Dm644 {} "$pkgdir/usr/lib/$pkgname/"{} \;
+ install -m644 "$srcdir/AssimpNet.dll.config" "$pkgdir/usr/lib/$pkgname/"
+ find "$pkgdir" -name '*.dll' -exec gacutil -i {} -root "$pkgdir/usr/lib" \;
+ install -Dm644 "$srcdir/assimp-net.pc.in" "$pkgdir/usr/lib/pkgconfig/assimp-net.pc"
+ sed -i "s,@VERSION@,$pkgver," "$pkgdir/usr/lib/pkgconfig/assimp-net.pc"
+}
diff --git a/assimp-net.pc.in b/assimp-net.pc.in
new file mode 100755
index 000000000000..95ce3ed8484a
--- /dev/null
+++ b/assimp-net.pc.in
@@ -0,0 +1,9 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib
+
+Name: AssimpNet
+Description: A .NET wrapper for the Open Asset Import Library (Assimp).
+Version: @VERSION@
+Requires: opentk
+Libs: -r:${libdir}/assimp-net/AssimpNet.dll