summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStezko2024-03-21 21:33:18 +0500
committerStezko2024-03-21 21:33:18 +0500
commitbbee8b0386c68778ebbe9e1fd6039c8cc3c17e07 (patch)
tree8a0e5cb2621a6f2d90ed5c3f176b6cf80f0ff168
parentc6b8904807123ccaff8e7c203f59115a07db1bf2 (diff)
downloadaur-bbee8b0386c68778ebbe9e1fd6039c8cc3c17e07.tar.gz
add make libtiff
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f037db678c7..279a6f79d723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = assistant
pkgdesc = Secure remote access to computers over a local network or over the Internet.
pkgver = 5.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://xn--80akicokc0aablc.xn--p1ai/
install = assistant.install
arch = x86_64
@@ -11,6 +11,8 @@ pkgbase = assistant
depends = gtk-engine-murrine
options = !strip
source = https://xn--80akicokc0aablc.xn--p1ai/%D1%81%D0%BA%D0%B0%D1%87%D0%B0%D1%82%D1%8C/Download/972
+ source = https://github.com/libsdl-org/libtiff/archive/refs/tags/v4.5.0.tar.gz
md5sums = 8BCB7690394CA23CFBFA4DBB93BE257E
+ md5sums = c072e49de5bfdee6a2c2456dc15a56c2
pkgname = assistant
diff --git a/PKGBUILD b/PKGBUILD
index 2e9c98627e7b..055d5b39aa99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,38 @@
pkgname=assistant
pkgver=5.6.2
-pkgrel=1
+pkgrel=2
_pkg=972
pkgdesc='Secure remote access to computers over a local network or over the Internet.'
-_pkgdesc_ru='Удобный инструмент для безопасного удаленного доступа и решения задач.'
arch=('x86_64')
license=('custom:SAFIB LTD')
url="https://xn--80akicokc0aablc.xn--p1ai/"
depends=('bash' 'gtk2' 'gtk-engine-murrine')
options=('!strip')
install=${pkgname}.install
-source=(${url}%D1%81%D0%BA%D0%B0%D1%87%D0%B0%D1%82%D1%8C/Download/${_pkg})
-md5sums=('8BCB7690394CA23CFBFA4DBB93BE257E')
+source=("${url}%D1%81%D0%BA%D0%B0%D1%87%D0%B0%D1%82%D1%8C/Download/${_pkg}"
+ "https://github.com/libsdl-org/libtiff/archive/refs/tags/v4.5.0.tar.gz")
+md5sums=('8BCB7690394CA23CFBFA4DBB93BE257E'
+ 'c072e49de5bfdee6a2c2456dc15a56c2')
+
+build() {
+
+ # Libtiff build, package requires 4.5.0 version
+
+ tar -xvf v4.5.0.tar.gz
+ cd "libtiff-4.5.0"
+ autoreconf -fi
+ ./configure
+ make
+}
+
package() {
sh "${_pkg}" --tar -xvf
mkdir ${pkgdir}/opt
- tar -C ${pkgdir}/opt/ -xvf ${pkgname}.tar.gz
- install -Dm644 ${pkgdir}/opt/${pkgname}/license/License.rtf "$pkgdir/usr/share/licenses/${pkgname}/License.rtf"
+ tar -C ${pkgdir}/opt/ -xvf ${pkgname}.tar.gz
+ cp "${srcdir}/libtiff-4.5.0/libtiff/.libs/libtiff.so.6.0.0" "${pkgdir}/opt/${pkgname}/lib/libtiff.so.6"
+ install -Dm644 "${pkgdir}/opt/${pkgname}/license/License.rtf" "${pkgname}/usr/share/licenses/${pkgname}/License.rtf"
+ find "${pkgdir}" -type d -print0 |xargs -0 chmod 755
}