summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillipe Smith2015-11-04 21:34:55 -0200
committerPhillipe Smith2015-11-04 21:34:55 -0200
commit6b64c0c0b4958f2a8b5a9399384c5e8414876a9f (patch)
tree390f404bca9a3bf928bf599723a2283851939995
parent5801f5a37207f71bae180bc257dbb3674aaf13fd (diff)
parentd6fbe65c88e34d2c183bf19ca578be206bef6c1c (diff)
downloadaur-6b64c0c0b4958f2a8b5a9399384c5e8414876a9f.tar.gz
Removed magic tags from astah_community.xml
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD60
-rw-r--r--astah-community.install14
3 files changed, 48 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ded21de94db1..88d1c56a8484 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,11 +3,13 @@ pkgbase = astah-community
pkgver = 7.0.0
pkgrel = 1
url = http://astah.change-vision.com/en/product/astah-community.html
+ install = astah-community.install
arch = any
license = custom
depends = java-runtime
provides = astah_community
conflicts = astah_community
+ conflicts = astah-professional
source = http://cdn.astah.net/downloads/astah-community-7_0_0-846701.zip
source = astah_community.desktop
source = astah_community.xml
@@ -16,7 +18,7 @@ pkgbase = astah-community
source = LICENSE
md5sums = 24ac9f33bf45a2a592d3f7571437b031
md5sums = e374756203ba7e4a52309cbe38208683
- md5sums = d728cbad449409131ed96edf89053caf
+ md5sums = d821b7726b61ce1c15ef84e31c0c0505
md5sums = b20ec64a7e6b1ad395c6eed7e8a851b7
md5sums = 95e5566bcef2eb2f7ee5a8ec99eae8af
md5sums = 3b5f3a3c4e453544e9c665c7950960fc
diff --git a/PKGBUILD b/PKGBUILD
index 9666dcfeb63e..5e5f41ec0a4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,40 @@
# Maintainer: Phillipe Smith <phillipe@archlinux.com.br>
pkgname=astah-community
+_pkgname=${pkgname/-/_}
pkgver=7.0.0
+_pkgver=${pkgver//./_}
pkgrel=1
-_altpkgname=astah_community
-_realpkgrel=846701
-pkgdesc='Lightweight, easy-to-use, and free UML2.x modeler'
-arch=('any')
-url='http://astah.change-vision.com/en/product/astah-community.html'
-license=('custom')
-depends=('java-runtime')
-provides=('astah_community')
-conflicts=('astah_community')
-source=("http://cdn.astah.net/downloads/${pkgname}-${pkgver//./_}-${_realpkgrel}.zip"
- 'astah_community.desktop'
- 'astah_community.xml'
- 'astah_community.png'
- 'astah_splash_community.png'
- 'LICENSE')
-md5sums=('24ac9f33bf45a2a592d3f7571437b031'
- 'e374756203ba7e4a52309cbe38208683'
- 'd821b7726b61ce1c15ef84e31c0c0505'
- 'b20ec64a7e6b1ad395c6eed7e8a851b7'
- '95e5566bcef2eb2f7ee5a8ec99eae8af'
- '3b5f3a3c4e453544e9c665c7950960fc')
+_pkgrel=846701
+pkgdesc="Lightweight, easy-to-use, and free UML2.x modeler"
+arch=("any")
+license=("custom")
+depends=("java-runtime")
+provides=("$_pkgname")
+conflicts=("$_pkgname" "astah-professional")
+install="${pkgname}.install"
+url="http://astah.change-vision.com/en/product/${pkgname}.html"
+source=("http://cdn.astah.net/downloads/${pkgname}-${_pkgver}-${_pkgrel}.zip"
+ "${_pkgname}.desktop"
+ "${_pkgname}.xml"
+ "${_pkgname}.png"
+ "astah_splash_community.png"
+ "LICENSE")
+md5sums=("24ac9f33bf45a2a592d3f7571437b031"
+ "e374756203ba7e4a52309cbe38208683"
+ "d821b7726b61ce1c15ef84e31c0c0505"
+ "b20ec64a7e6b1ad395c6eed7e8a851b7"
+ "95e5566bcef2eb2f7ee5a8ec99eae8af"
+ "3b5f3a3c4e453544e9c665c7950960fc")
package() {
- install -Dm755 $srcdir/$_altpkgname/astah $pkgdir/usr/bin/astah || return 1
- install -Dm755 $srcdir/$_altpkgname/astah-command.sh $pkgdir/usr/bin/astah-command || return 1
- install -Dm644 $srcdir/${_altpkgname}.desktop $pkgdir/usr/share/applications/${_altpkgname}.desktop || return 1
- install -Dm644 $srcdir/${_altpkgname}.xml $pkgdir/usr/share/mime/packages/${_altpkgname}.xml || return 1
- install -Dm644 $srcdir/${_altpkgname}.png $pkgdir/usr/share/pixmaps/${_altpkgname}.png || return 1
- install -Dm644 $srcdir/astah_splash_community.png ${pkgdir}/usr/lib/${_altpkgname}/astah_splash_community.png || return 1
- install -Dm644 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${_altpkgname}/LICENSE || return 1
- cp -rf $srcdir/$_altpkgname/ ${pkgdir}/usr/lib/$pkgname || return 1
+ install -Dm755 $srcdir/$_pkgname/astah $pkgdir/usr/bin/astah || return 1
+ install -Dm755 $srcdir/$_pkgname/astah-command.sh $pkgdir/usr/bin/astah-command || return 1
+ install -Dm644 $srcdir/${_pkgname}.desktop $pkgdir/usr/share/applications/${_pkgname}.desktop || return 1
+ install -Dm644 $srcdir/${_pkgname}.xml $pkgdir/usr/share/mime/packages/${_pkgname}.xml || return 1
+ install -Dm644 $srcdir/${_pkgname}.png $pkgdir/usr/share/pixmaps/${_pkgname}.png || return 1
+ install -Dm644 $srcdir/astah_splash_community.png ${pkgdir}/usr/lib/${_pkgname}/astah_splash_community.png || return 1
+ install -Dm644 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE || return 1
+ cp -rf $srcdir/$_pkgname/ ${pkgdir}/usr/lib/$pkgname || return 1
chmod +x $pkgdir/usr/lib/${pkgname}/astah{,-command.sh}
sed -i -r "s|^(ASTAH_HOME=).*|\1/usr/lib/$pkgname|" ${pkgdir}/usr/bin/astah
}
diff --git a/astah-community.install b/astah-community.install
new file mode 100644
index 000000000000..4de4c2fd41af
--- /dev/null
+++ b/astah-community.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-desktop-database /usr/share/applications
+ update-mime-database /usr/share/mime
+ gtk-update-icon-cache -t /usr/share/icons/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+