summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:14:11 +0300
committerAchilleas Pipinellis2015-06-10 09:14:11 +0300
commit90eb9ca057fac24efbee52a588b48eef7f134a31 (patch)
treeefdef9109db45d6a75683b8bb579299b09e76c48
downloadaur-90eb9ca057fac24efbee52a588b48eef7f134a31.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..773e4a5c7e3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = astakosclient
+ pkgdesc = A client for the astakos authentication service
+ pkgver = 0.15
+ pkgrel = 1
+ url = http://www.synnefo.org
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-objpool
+ depends = python2-simplejson
+ source = http://pypi.python.org/packages/source/a/astakosclient/astakosclient-0.15.tar.gz
+ md5sums = 1b51c3b9b7b2a693d21eee681000b948
+
+pkgname = astakosclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0846f9e576c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Axilleas Pipinellis <axilleas@archlinux.info>
+
+pkgname=astakosclient
+pkgver=0.15
+pkgrel=1
+pkgdesc="A client for the astakos authentication service"
+arch=('any')
+url=('http://www.synnefo.org')
+license=("BSD")
+depends=('python2' 'python2-objpool' 'python2-simplejson')
+makedepends=(python2-distribute)
+source=("http://pypi.python.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz")
+
+package() {
+
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" -O1
+# install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+md5sums=('1b51c3b9b7b2a693d21eee681000b948')