summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-06-15 14:12:56 +0300
committerMr.Smith19742023-06-15 14:12:56 +0300
commit361fbf17bc467300b9fa2fde08c636d8a2b07d48 (patch)
tree25f9248f84ca3b11e639d487365d69a38e29f70f
parent77f22af39be07f898a0c52d21af768dc30d0fe0e (diff)
downloadaur-361fbf17bc467300b9fa2fde08c636d8a2b07d48.tar.gz
Updated build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD36
2 files changed, 12 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 877e823e28d7..f11ebc77ba22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = astap-bin
pkgdesc = Astrometric (plate) solver, stacking of images, photometry and FITS viewer. Gtk2 version.
pkgver = 2023.05.31
- pkgrel = 2
+ pkgrel = 3
url = http://www.hnsky.org/astap.htm
arch = i686
arch = x86_64
@@ -11,6 +11,9 @@ pkgbase = astap-bin
optdepends = d05-star-db-astap: 100MB database of 500 stars per square degree, reliable with 0.6-10° FOV
optdepends = d20-star-db-astap: 400MB database of 2000 stars per square degree, reliable with 0.3-10° FOV
optdepends = d50-star-db-astap: 900MB database of 5000 stars per square degree, reliable with 0.2-10° FOV
+ conflicts = astap
+ conflicts = astap-bin-qt5
+ conflicts = astap-cli
source_i686 = astap_i386.deb::https://sourceforge.net/projects/astap-program/files/linux_installer/astap_i386.deb/download
sha256sums_i686 = a3d2fd2b941979da09e520d32d340beb20786b3e75e1d60e740d0b5c8e2ca8e1
source_x86_64 = astap_amd64.deb::https://sourceforge.net/projects/astap-program/files/linux_installer/astap_amd64.deb/download
diff --git a/PKGBUILD b/PKGBUILD
index b9b8bf8aea57..fab16cf9f0a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: WhiredPlanck
-
pkgname=astap-bin
_pkgname=astap
pkgver=2023.05.31
-pkgrel=2
+pkgrel=3
pkgdesc="Astrometric (plate) solver, stacking of images, photometry and FITS viewer. Gtk2 version."
arch=('i686' 'x86_64')
url="http://www.hnsky.org/astap.htm"
@@ -17,42 +16,23 @@ optdepends=('hyperleda-galaxy-db-astap: 25MB database of 1.3m galaxies and 171k
'd05-star-db-astap: 100MB database of 500 stars per square degree, reliable with 0.6-10° FOV'
'd20-star-db-astap: 400MB database of 2000 stars per square degree, reliable with 0.3-10° FOV'
'd50-star-db-astap: 900MB database of 5000 stars per square degree, reliable with 0.2-10° FOV')
+conflicts=('astap' 'astap-bin-qt5' 'astap-cli')
mkinfo() { echo -e "[\e[96mMKINFO\e[0m]: \e[1m$*\e[0m"; }
-build() {
+prepare() {
if [[ "$CARCH" == "i686" ]]; then
ar x "${srcdir}/${_pkgname}_i386.deb"
else
ar x "${srcdir}/${_pkgname}_amd64.deb"
fi
-}
-package() {
- mkinfo "Extracting data.tat.xz ..."
+ mkinfo "Extracting data.tar.xz ..."
tar -xpvf "${srcdir}"/data.tar.xz
+}
- mkinfo "Preparing needed directories ..."
- mkdir -pv "${pkgdir}"/usr/{bin,lib,licenses/"${_pkgname}"}
-
- mkinfo "Install binaries ..."
- cp -rv "${srcdir}"/opt/"${_pkgname}" "${pkgdir}"/usr/lib/
-
- mkinfo "Installing shared files ..."
- cp -rv "${srcdir}"/usr/share "${pkgdir}"/usr
-
- mkinfo "Installing licenses ..."
- install -Dvm644 "${pkgdir}"/usr/lib/"${_pkgname}"/*.txt \
- -t "${pkgdir}/usr/share/licenses/${_pkgname}"
-
- mkinfo "Modifying path to executable in desktop file ..."
- sed -e "s|Exec=/opt/astap/astap|Exec=astap|g" \
- -i "${pkgdir}"/usr/share/applications/*.desktop
-
- mkinfo "Removeing unneeded resources ..."
- rm -rv "${pkgdir}"/usr/lib/"${_pkgname}"/*.txt
-
- mkinfo "Creating application symlinks to /usr/bin ..."
- ln -sv ../lib/"${_pkgname}"/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}"
+package() {
+ cp -r "${srcdir}"/opt "${pkgdir}"/opt
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
}