summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWhiredPlanck2022-02-08 21:06:27 +0800
committerWhiredPlanck2022-02-08 21:06:27 +0800
commitf2dca4ce2534bb312c83786c6ea9204e7e9bace8 (patch)
treecb7e65b28c601d7c220346d69b579c1066be8a16
parentf30219b9106027f9cdb0e8536ea3507f900bc51a (diff)
downloadaur-f2dca4ce2534bb312c83786c6ea9204e7e9bace8.tar.gz
astap-bin: modify path to executable in .desktop; create application symlinks
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b43aa37d2910..84790406399e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,6 +48,13 @@ package() {
install -Dvm644 "${pkgdir}"/usr/lib/"${_pkgname}"/*.txt \
-t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ mkinfo "Modifying path to executable in desktop file ..."
+ sed -e "s|Exec=/opt/astap/astap|Exec=astap|g" \
+ -i "${pkgdir}"/usr/share/applications/*.desktop
+
mkinfo "Removeing unneeded resources ..."
rm -rv "${pkgdir}"/usr/lib/"${_pkgname}"/*.txt
+
+ mkinfo "Creating application symlinks to /usr/bin ..."
+ ln -sv ../lib/"${_pkgname}"/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}"
}