summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWren Baxter2023-07-02 12:49:03 -0400
committerWren Baxter2023-07-02 12:49:03 -0400
commit24182d8eae2f0e52c5994dde35c5d6aa6891889b (patch)
treeb4f14d91568c971218a2931f11f74039a2f98ecf
parente66662613248154b6e476c3b5e070982874692df (diff)
downloadaur-24182d8eae2f0e52c5994dde35c5d6aa6891889b.tar.gz
update to 2023.07.01
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efa94c9edc52..9c4775da7ef0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,29 @@
pkgbase = astap-bin-qt5
pkgdesc = Astrometric (plate) solver, stacking of images, photometry and FITS viewer
- pkgver = 2023.06.08
+ pkgver = 2023.07.01
pkgrel = 1
url = https://www.hnsky.org/astap.htm
arch = x86_64
license = LGPL3
makedepends = tar
- depends = qt5-base
- depends = qt5-x11extras
depends = qt5pas
+ depends = libjpeg-turbo
+ depends = libx11
+ depends = gcc-libs
+ depends = zlib
+ depends = glibc
optdepends = hyperleda-galaxy-db-astap: 25MB database of 1.3m galaxies and 171k other non-star objects
optdepends = w08-star-db-astap: 250KB database of stars up to magnitude 8, reliable above 20° FOV
+ optdepends = g05-star-db-astap: same as d05 but with larger 10 degree tiles, reliable with 1-20° FOV
optdepends = d05-star-db-astap: 100MB database of 500 stars per square degree, reliable with 0.6-10° FOV
optdepends = d20-star-db-astap: 400MB database of 2000 stars per square degree, reliable with 0.3-10° FOV
optdepends = d50-star-db-astap: 900MB database of 5000 stars per square degree, reliable with 0.2-10° FOV
+ optdepends = v50-star-db-astap: 1GB, same as d50 but includes photometry info, reliable with 0.2-10° FOV
+ optdepends = d80-star-db-astap: 1.2GB database of 8000 stars per square degree, reliable with 0.15-10° FOV
provides = astap
conflicts = astap-bin
- noextract = astap-2023.06.08.tar.gz
- source = astap-2023.06.08.tar.gz::https://github.com/wrenby/astap-backups/raw/285daf3c41d9cc69732d201c11d59164b77076bf/astap_amd64_qt5.tar.gz
- md5sums = 1e953c28a53b8182190cfa51a85dc295
+ noextract = astap-2023.07.01.tar.gz
+ source = astap-2023.07.01.tar.gz::https://github.com/wrenby/astap-backups/raw/b4b4d56c2cfeba69381cc04a68181de5394f2502/astap_amd64_qt5.tar.gz
+ md5sums = 5ece858847782b91e75dcf2b1f3962ac
pkgname = astap-bin-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 459a65c8c6a9..fd94902496b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wren Baxter <aur [at] wren.dev>
pkgname=astap-bin-qt5
-pkgver=2023.06.08
+pkgver=2023.07.01
pkgrel=1
pkgdesc="Astrometric (plate) solver, stacking of images, photometry and FITS viewer"
provides=('astap')
@@ -9,23 +9,25 @@ conflicts=('astap-bin' )
arch=('x86_64') # no 32-bit version provided, consider building from source with the `astap` package
url="https://www.hnsky.org/astap.htm"
license=('LGPL3')
-source=("astap-${pkgver}.tar.gz::https://github.com/wrenby/astap-backups/raw/285daf3c41d9cc69732d201c11d59164b77076bf/astap_amd64_qt5.tar.gz")
-md5sums=('1e953c28a53b8182190cfa51a85dc295')
+source=("astap-${pkgver}.tar.gz::https://github.com/wrenby/astap-backups/raw/b4b4d56c2cfeba69381cc04a68181de5394f2502/astap_amd64_qt5.tar.gz")
+md5sums=('5ece858847782b91e75dcf2b1f3962ac')
noextract=("astap-${pkgver}.tar.gz") # bsdtar can't handle this archive because it contains a self-referential hardlink
-depends=('qt5-base' 'qt5-x11extras' 'qt5pas') # qt5 + pascal bindings
makedepends=('tar') # but gnu tar is just fine
+depends=('qt5pas' 'libjpeg-turbo' 'libx11' 'gcc-libs' 'zlib' 'glibc')
# these databases aren't hard-limited by the bounds provided here
# databases can identify 100% of the sky in the ranges provided,
# but can also identify some regions of the sky with FOVs smaller or larger than the given bounds
-# there is no downside to choosing d50 compared to d05, other than the larger file size
-# the new g05 database covering the 10-20° gap does not yet have an associated package on the AUR
+# there is no downside to choosing the bigger d__ databases, other than the larger file size
optdepends=('hyperleda-galaxy-db-astap: 25MB database of 1.3m galaxies and 171k other non-star objects'
- 'w08-star-db-astap: 250KB database of stars up to magnitude 8, reliable above 20° FOV'
- 'd05-star-db-astap: 100MB database of 500 stars per square degree, reliable with 0.6-10° FOV'
- 'd20-star-db-astap: 400MB database of 2000 stars per square degree, reliable with 0.3-10° FOV'
- 'd50-star-db-astap: 900MB database of 5000 stars per square degree, reliable with 0.2-10° FOV')
+ 'w08-star-db-astap: 250KB database of stars up to magnitude 8, reliable above 20° FOV'
+ 'g05-star-db-astap: same as d05 but with larger 10 degree tiles, reliable with 1-20° FOV'
+ 'd05-star-db-astap: 100MB database of 500 stars per square degree, reliable with 0.6-10° FOV'
+ 'd20-star-db-astap: 400MB database of 2000 stars per square degree, reliable with 0.3-10° FOV'
+ 'd50-star-db-astap: 900MB database of 5000 stars per square degree, reliable with 0.2-10° FOV'
+ 'v50-star-db-astap: 1GB, same as d50 but includes photometry info, reliable with 0.2-10° FOV'
+ 'd80-star-db-astap: 1.2GB database of 8000 stars per square degree, reliable with 0.15-10° FOV')
prepare() {
tar xpf "astap-${pkgver}.tar.gz"
@@ -33,5 +35,5 @@ prepare() {
package() {
cp -r "${srcdir}"/opt "${pkgdir}"/opt
- cp -r "${srcdir}"/usr "${pkgdir}"/usr
+ cp -r "${srcdir}"/usr/local "${pkgdir}"/usr
}