summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-22 16:16:30 -0300
committerDaniel Bermond2022-07-22 16:16:30 -0300
commit142e25ddf5f1780c8cbcba6037e114c50e5d573c (patch)
tree2b30093f03332571c19d39553d7ef2c3656f4674
parent372e6c021a2efc96dd3e35b93d9d5fe0e6bf6cfb (diff)
downloadaur-142e25ddf5f1780c8cbcba6037e114c50e5d573c.tar.gz
Update to version 4.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--010-astc-encoder-fix-install.patch19
-rw-r--r--010-astc-encoder-use-shared-library.patch (renamed from 020-astc-encoder-use-shared-library.patch)14
-rw-r--r--PKGBUILD12
4 files changed, 20 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af914a2e30a9..be59e71e7913 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 3.7
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,13 +9,11 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.7
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.0.0
source = git+https://github.com/google/googletest.git
- source = 010-astc-encoder-fix-install.patch
- source = 020-astc-encoder-use-shared-library.patch
+ source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92
- sha256sums = e64fe99e5dc5f014156f58eb7ea179c922cafd71fecbd704c86ebaa3b04ed9e6
+ sha256sums = dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210
pkgname = astc-encoder
diff --git a/010-astc-encoder-fix-install.patch b/010-astc-encoder-fix-install.patch
deleted file mode 100644
index 2c504feff9c4..000000000000
--- a/010-astc-encoder-fix-install.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -30,7 +30,7 @@ set(CMAKE_CXX_STANDARD 14)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
- set(CMAKE_CXX_EXTENSIONS OFF)
- set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
--set(PACKAGE_ROOT astcenc)
-+set(PACKAGE_ROOT bin)
-
- include(CTest)
-
---- a/Source/UnitTest/cmake_core.cmake
-+++ b/Source/UnitTest/cmake_core.cmake
-@@ -135,4 +135,4 @@ target_link_libraries(${ASTC_TEST}
- add_test(NAME ${ASTC_TEST}
- COMMAND ${ASTC_TEST})
-
--install(TARGETS ${ASTC_TEST} DESTINATION ${PACKAGE_ROOT})
-+
diff --git a/020-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
index 06c570754914..a1efe29e5c15 100644
--- a/020-astc-encoder-use-shared-library.patch
+++ b/010-astc-encoder-use-shared-library.patch
@@ -43,20 +43,28 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -277,10 +281,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -310,16 +314,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
-astcenc_set_properties(${ASTC_TARGET}-static)
+astcenc_set_properties(${ASTC_TARGET})
+- target_compile_options(${ASTC_TARGET}-static
++ target_compile_options(${ASTC_TARGET}
+ PRIVATE
+ $<$<CXX_COMPILER_ID:MSVC>:/W4>)
+
if(${CLI})
- astcenc_set_properties(${ASTC_TARGET})
+ astcenc_set_properties(${ASTC_TARGET}-bin)
- string(TIMESTAMP astcencoder_YEAR "%Y")
+- target_compile_options(${ASTC_TARGET}
++ target_compile_options(${ASTC_TARGET}-bin
+ PRIVATE
+ $<$<CXX_COMPILER_ID:MSVC>:/W3>)
-@@ -289,9 +293,10 @@ if(${CLI})
+@@ -330,9 +334,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index 30675c9f3824..eca3abf01d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.7
+pkgver=4.0.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -11,19 +11,16 @@ depends=('gcc-libs')
makedepends=('git' 'cmake' 'python')
source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'git+https://github.com/google/googletest.git'
- '010-astc-encoder-fix-install.patch'
- '020-astc-encoder-use-shared-library.patch')
+ '010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- '5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
- 'e64fe99e5dc5f014156f58eb7ea179c922cafd71fecbd704c86ebaa3b04ed9e6')
+ 'dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder submodule update
- patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-fix-install.patch"
- patch -d astc-encoder -Np1 -i "${srcdir}/020-astc-encoder-use-shared-library.patch"
+ patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}
build() {
@@ -47,4 +44,5 @@ package() {
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
ln -s libastcenc-sse2.so "${pkgdir}/usr/lib/libastcenc.so"
+ rm "${pkgdir}/usr/bin"/test-unit*
}