summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-02-27 16:03:36 -0300
committerDaniel Bermond2022-02-27 16:03:36 -0300
commit1bf6255a873ba5a5e095e8b038dba6cfc204ccec (patch)
tree161c1dac50e5ea4ea490cbb5a06175eb7f15d29c
parent70f18e8052afdfcdca77a9a63f7b9f72a8bb3871 (diff)
downloadaur-1bf6255a873ba5a5e095e8b038dba6cfc204ccec.tar.gz
Update to version 3.4
-rw-r--r--.SRCINFO6
-rw-r--r--020-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58a6b91b2712..7447a652fe9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 3.3
+ pkgver = 3.4
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,13 +9,13 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.3
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.4
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-fix-install.patch
source = 020-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92
- sha256sums = a2f0c20dc8f08c3d8704721e5d6e8462eacf03a7399de7733452e47a9368001f
+ sha256sums = 9f699f055d9a070c36535bee5447696e2f7a18cf533125e84a112551956b26e6
pkgname = astc-encoder
diff --git a/020-astc-encoder-use-shared-library.patch b/020-astc-encoder-use-shared-library.patch
index c312ec7faada..3ff25c1af6fc 100644
--- a/020-astc-encoder-use-shared-library.patch
+++ b/020-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -257,10 +261,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -263,10 +267,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -56,7 +56,7 @@
string(TIMESTAMP astcencoder_YEAR "%Y")
-@@ -269,9 +273,10 @@ if(${CLI})
+@@ -275,9 +279,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index 758a4c5221b4..b975a20caa99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.3
+pkgver=3.4
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
sha256sums=('SKIP'
'SKIP'
'5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
- 'a2f0c20dc8f08c3d8704721e5d6e8462eacf03a7399de7733452e47a9368001f')
+ '9f699f055d9a070c36535bee5447696e2f7a18cf533125e84a112551956b26e6')
prepare() {
git -C astc-encoder submodule init