summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-03-18 09:41:49 -0300
committerDaniel Bermond2022-03-18 09:41:49 -0300
commit261ba099d0f6355ef4bcfc535010f1a63a30d64b (patch)
tree6ad5dddd81f3a474ba3e183a47551f717eab587d
parent1bf6255a873ba5a5e095e8b038dba6cfc204ccec (diff)
downloadaur-261ba099d0f6355ef4bcfc535010f1a63a30d64b.tar.gz
Update to version 3.5
-rw-r--r--.SRCINFO6
-rw-r--r--020-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7447a652fe9a..c7f09ac3b3fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 3.4
+ pkgver = 3.5
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,13 +9,13 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.4
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.5
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-fix-install.patch
source = 020-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92
- sha256sums = 9f699f055d9a070c36535bee5447696e2f7a18cf533125e84a112551956b26e6
+ sha256sums = 5507d79c2033b4258eed77e1498cf835a57b7a9d4b898100c4b1ceff2b230f73
pkgname = astc-encoder
diff --git a/020-astc-encoder-use-shared-library.patch b/020-astc-encoder-use-shared-library.patch
index 3ff25c1af6fc..06cf90ce1fe1 100644
--- a/020-astc-encoder-use-shared-library.patch
+++ b/020-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -263,10 +267,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -266,10 +270,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -56,7 +56,7 @@
string(TIMESTAMP astcencoder_YEAR "%Y")
-@@ -275,9 +279,10 @@ if(${CLI})
+@@ -278,9 +282,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index b975a20caa99..4890f81a6e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.4
+pkgver=3.5
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
sha256sums=('SKIP'
'SKIP'
'5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
- '9f699f055d9a070c36535bee5447696e2f7a18cf533125e84a112551956b26e6')
+ '5507d79c2033b4258eed77e1498cf835a57b7a9d4b898100c4b1ceff2b230f73')
prepare() {
git -C astc-encoder submodule init