summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-01-31 00:25:35 -0300
committerDaniel Bermond2023-01-31 00:25:35 -0300
commit324ca4fca6f0744e75a41a791eb5f2d7d45d5c6c (patch)
treed3ddd3e3e63b577eaf4d8ca237641684aab2ee01
parentdc1d0f8d01b6eb05a23be0bfda22aa9be8e0e8cb (diff)
downloadaur-324ca4fca6f0744e75a41a791eb5f2d7d45d5c6c.tar.gz
Update to version 4.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--010-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6ab8ef89944..93cabf7789db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 4.3.0
+ pkgver = 4.3.1
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.3.0
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.3.1
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 29a968ae8df5391320eb804d8f79af75a18219df3734cbb5bced67d82cc7a661
+ sha256sums = b17d8f02273a0e58c9055dc5696965b62fbf833923b513d3685eda1af2cf13f4
pkgname = astc-encoder
diff --git a/010-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
index 03b9e32b0079..93a664a53ba2 100644
--- a/010-astc-encoder-use-shared-library.patch
+++ b/010-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -308,16 +312,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -309,16 +313,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -64,7 +64,7 @@
PRIVATE
$<$<CXX_COMPILER_ID:MSVC>:/W3>)
-@@ -328,9 +332,10 @@ if(${CLI})
+@@ -329,9 +333,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index ec6e1e6a78d6..cfa1cd8815b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.3.0
+pkgver=4.3.1
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -14,7 +14,7 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- '29a968ae8df5391320eb804d8f79af75a18219df3734cbb5bced67d82cc7a661')
+ 'b17d8f02273a0e58c9055dc5696965b62fbf833923b513d3685eda1af2cf13f4')
prepare() {
git -C astc-encoder submodule init