summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-04-29 18:04:53 -0300
committerDaniel Bermond2022-04-29 18:04:53 -0300
commit372e6c021a2efc96dd3e35b93d9d5fe0e6bf6cfb (patch)
tree1b8bf68e773b12a686724fdb5e08348facbbb249
parent804d4aaf780fd74645907795ef0328e7c89d4365 (diff)
downloadaur-372e6c021a2efc96dd3e35b93d9d5fe0e6bf6cfb.tar.gz
Update to version 3.7
-rw-r--r--.SRCINFO6
-rw-r--r--020-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 494581165595..af914a2e30a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 3.6
+ pkgver = 3.7
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,13 +9,13 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.6
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.7
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-fix-install.patch
source = 020-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92
- sha256sums = 5507d79c2033b4258eed77e1498cf835a57b7a9d4b898100c4b1ceff2b230f73
+ sha256sums = e64fe99e5dc5f014156f58eb7ea179c922cafd71fecbd704c86ebaa3b04ed9e6
pkgname = astc-encoder
diff --git a/020-astc-encoder-use-shared-library.patch b/020-astc-encoder-use-shared-library.patch
index 06cf90ce1fe1..06c570754914 100644
--- a/020-astc-encoder-use-shared-library.patch
+++ b/020-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -266,10 +270,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -277,10 +281,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -56,7 +56,7 @@
string(TIMESTAMP astcencoder_YEAR "%Y")
-@@ -278,9 +282,10 @@ if(${CLI})
+@@ -289,9 +293,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index a1fcbc47ecce..30675c9f3824 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.6
+pkgver=3.7
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
sha256sums=('SKIP'
'SKIP'
'5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
- '5507d79c2033b4258eed77e1498cf835a57b7a9d4b898100c4b1ceff2b230f73')
+ 'e64fe99e5dc5f014156f58eb7ea179c922cafd71fecbd704c86ebaa3b04ed9e6')
prepare() {
git -C astc-encoder submodule init