summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-11-08 14:22:54 -0300
committerDaniel Bermond2021-11-08 14:22:54 -0300
commit70f18e8052afdfcdca77a9a63f7b9f72a8bb3871 (patch)
tree6e8407a8ff2e7b48e53a087cd95f6241831768b8
parent5eb88e1688826db7ac26705769ecc2ad1a807c8b (diff)
downloadaur-70f18e8052afdfcdca77a9a63f7b9f72a8bb3871.tar.gz
Update to version 3.3
-rw-r--r--.SRCINFO8
-rw-r--r--010-astc-encoder-fix-install.patch2
-rw-r--r--020-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD6
4 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 706141a1883d..58a6b91b2712 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 3.2
+ pkgver = 3.3
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,13 +9,13 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.2
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=3.3
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-fix-install.patch
source = 020-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 9c29ba69d8e9e10683ba965d2e13cdd939e477dcbef6e8d7700dc13d50cc9974
- sha256sums = df157a7b4041da008ca6ebeb7fbe7263ada7298e4e2190ba7f42b7871f881581
+ sha256sums = 5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92
+ sha256sums = a2f0c20dc8f08c3d8704721e5d6e8462eacf03a7399de7733452e47a9368001f
pkgname = astc-encoder
diff --git a/010-astc-encoder-fix-install.patch b/010-astc-encoder-fix-install.patch
index 1c5f8dea1dad..2c504feff9c4 100644
--- a/010-astc-encoder-fix-install.patch
+++ b/010-astc-encoder-fix-install.patch
@@ -11,7 +11,7 @@
--- a/Source/UnitTest/cmake_core.cmake
+++ b/Source/UnitTest/cmake_core.cmake
-@@ -126,4 +126,4 @@ target_link_libraries(${ASTC_TEST}
+@@ -135,4 +135,4 @@ target_link_libraries(${ASTC_TEST}
add_test(NAME ${ASTC_TEST}
COMMAND ${ASTC_TEST})
diff --git a/020-astc-encoder-use-shared-library.patch b/020-astc-encoder-use-shared-library.patch
index 20786d37f001..c312ec7faada 100644
--- a/020-astc-encoder-use-shared-library.patch
+++ b/020-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -247,10 +251,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -257,10 +261,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -56,7 +56,7 @@
string(TIMESTAMP astcencoder_YEAR "%Y")
-@@ -259,9 +263,10 @@ if(${CLI})
+@@ -269,9 +273,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index 64a2964ed703..758a4c5221b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.2
+pkgver=3.3
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -15,8 +15,8 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'020-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- '9c29ba69d8e9e10683ba965d2e13cdd939e477dcbef6e8d7700dc13d50cc9974'
- 'df157a7b4041da008ca6ebeb7fbe7263ada7298e4e2190ba7f42b7871f881581')
+ '5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
+ 'a2f0c20dc8f08c3d8704721e5d6e8462eacf03a7399de7733452e47a9368001f')
prepare() {
git -C astc-encoder submodule init