summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-06-21 21:26:44 -0300
committerDaniel Bermond2023-06-21 21:26:44 -0300
commitb6e53282dc904cea70ed3c96a169d3c14da1412d (patch)
tree6e7febfb32d4a0d045447db0fe2e66fb02ab71d3
parent9878083aac2fec5e72cd3f3b760751589bae672a (diff)
downloadaur-b6e53282dc904cea70ed3c96a169d3c14da1412d.tar.gz
Update to version 4.5.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0465d5961db..4c1e612cabc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 4.4.0
+ pkgver = 4.5.0
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.4.0
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.5.0
source = git+https://github.com/google/googletest.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6e32329c41df..d826a511e576 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.4.0
+pkgver=4.5.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -25,11 +25,10 @@ build() {
-G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DSHAREDLIB:BOOL='ON' \
- -DISA_AVX2:BOOL='ON' \
- -DISA_SSE41:BOOL='ON' \
- -DISA_SSE2:BOOL='ON' \
- -DUNITTEST:BOOL='ON' \
+ -DASTCENC_SHAREDLIB:BOOL='ON' \
+ -DASTCENC_ISA_AVX2:BOOL='ON' \
+ -DASTCENC_ISA_SSE41:BOOL='ON' \
+ -DASTCENC_ISA_SSE2:BOOL='ON' \
-Wno-dev
cmake --build build
}
@@ -43,5 +42,4 @@ package() {
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
ln -s libastcenc-sse2-shared.so "${pkgdir}/usr/lib/libastcenc.so"
- rm "${pkgdir}/usr/bin"/test-unit*
}