summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-05-11 11:41:44 -0300
committerDaniel Bermond2024-05-11 11:41:44 -0300
commitea1ff2d96fefc650afc439ca411f8dfd38e54c2c (patch)
treea27007403db0e0604e230a9c5a334888d38ace88
parent5779baf31cd7bf7b3fd1e5a0be253faed5950712 (diff)
downloadaur-ea1ff2d96fefc650afc439ca411f8dfd38e54c2c.tar.gz
Update to version 4.8.0. Add fix for gcc14.
-rw-r--r--.SRCINFO12
-rw-r--r--010-astc-encoder-remove-werror.patch10
-rw-r--r--020-astc-encoder-remove-flags-unsupported-by-gcc14.patch87
-rw-r--r--PKGBUILD17
4 files changed, 117 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec15fb35ce02..d78b141334b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 4.7.0
+ pkgver = 4.8.0
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = git
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.7.0
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.8.0
source = git+https://github.com/google/googletest.git
+ source = 010-astc-encoder-remove-werror.patch
+ source = 020-astc-encoder-remove-flags-unsupported-by-gcc14.patch
+ sha256sums = 7f0858835a9ec611eaf05c6a095605378705ba8ad9ef6274b69ffe5e7755dc48
sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = fff998bd640aede9584b68d5f9cef9de785deef56ffc6d10fda6d112a6e649a2
+ sha256sums = 9d5773a29c2110fb9137471cd525701ddf95a7990a27e40b7d3e2cfd69719812
pkgname = astc-encoder
diff --git a/010-astc-encoder-remove-werror.patch b/010-astc-encoder-remove-werror.patch
new file mode 100644
index 000000000000..8514bd96588c
--- /dev/null
+++ b/010-astc-encoder-remove-werror.patch
@@ -0,0 +1,10 @@
+--- a/Source/cmake_core.cmake
++++ b/Source/cmake_core.cmake
+@@ -164,7 +164,6 @@ macro(astcenc_set_properties ASTCENC_TARGET_NAME ASTCENC_IS_VENEER)
+ $<${is_gnu_fe}:-Wall>
+ $<${is_gnu_fe}:-Wextra>
+ $<${is_gnu_fe}:-Wpedantic>
+- $<${is_gnu_fe}:-Werror>
+ $<${is_gnu_fe}:-Wshadow>
+ $<${is_gnu_fe}:-Wdouble-promotion>
+ $<${is_clang}:-Wdocumentation>
diff --git a/020-astc-encoder-remove-flags-unsupported-by-gcc14.patch b/020-astc-encoder-remove-flags-unsupported-by-gcc14.patch
new file mode 100644
index 000000000000..163943db1856
--- /dev/null
+++ b/020-astc-encoder-remove-flags-unsupported-by-gcc14.patch
@@ -0,0 +1,87 @@
+--- a/Source/cmake_core.cmake
++++ b/Source/cmake_core.cmake
+@@ -169,20 +169,13 @@ macro(astcenc_set_properties ASTCENC_TARGET_NAME ASTCENC_IS_VENEER)
+ $<${is_clang}:-Wdocumentation>
+
+ # Hide noise thrown up by Clang 10 and clang-cl
+- $<${is_gnu_fe}:-Wno-unknown-warning-option>
+- $<${is_gnu_fe}:-Wno-c++98-compat-pedantic>
+- $<${is_gnu_fe}:-Wno-c++98-c++11-compat-pedantic>
+ $<${is_gnu_fe}:-Wno-float-equal>
+ $<${is_gnu_fe}:-Wno-deprecated-declarations>
+- $<${is_gnu_fe}:-Wno-atomic-implicit-seq-cst>
+
+ # Clang 10 also throws up warnings we need to investigate (ours)
+ $<${is_gnu_fe}:-Wno-cast-align>
+ $<${is_gnu_fe}:-Wno-sign-conversion>
+- $<${is_gnu_fe}:-Wno-implicit-int-conversion>
+- $<${is_gnu_fe}:-Wno-shift-sign-overflow>
+ $<${is_gnu_fe}:-Wno-format-nonliteral>
+- $<${is_gnu_fe}:-Wno-reserved-identifier>
+ $<${is_gnu_fe}:-Wno-cast-function-type>
+
+ # Force DWARF4 for Valgrind profiling
+@@ -307,7 +300,7 @@ macro(astcenc_set_properties ASTCENC_TARGET_NAME ASTCENC_IS_VENEER)
+ $<${is_clangcl}:-msse2>
+ $<${is_gnu_fe}:-msse2>
+ $<${is_gnu_fe}:-mno-sse4.1>
+- $<${is_gnu_fe}:-Wno-unused-command-line-argument>)
++ )
+
+ elseif(${ASTCENC_ISA_SIMD} MATCHES "sse4.1")
+ target_compile_definitions(${ASTCENC_TARGET_NAME}
+@@ -324,13 +317,13 @@ macro(astcenc_set_properties ASTCENC_TARGET_NAME ASTCENC_IS_VENEER)
+ PRIVATE
+ $<${is_gnu_fe}:-msse2>
+ $<${is_gnu_fe}:-mno-sse4.1>
+- $<${is_gnu_fe}:-Wno-unused-command-line-argument>)
++ )
+ else()
+ target_compile_options(${ASTCENC_TARGET_NAME}
+ PRIVATE
+ $<${is_clangcl}:-msse4.1 -mpopcnt>
+ $<${is_gnu_fe}:-msse4.1 -mpopcnt>
+- $<${is_gnu_fe}:-Wno-unused-command-line-argument>)
++ )
+ endif()
+
+ elseif(${ASTCENC_ISA_SIMD} MATCHES "avx2")
+@@ -348,14 +341,14 @@ macro(astcenc_set_properties ASTCENC_TARGET_NAME ASTCENC_IS_VENEER)
+ PRIVATE
+ $<${is_gnu_fe}:-msse2>
+ $<${is_gnu_fe}:-mno-sse4.1>
+- $<${is_gnu_fe}:-Wno-unused-command-line-argument>)
++ )
+ else()
+ target_compile_options(${ASTCENC_TARGET_NAME}
+ PRIVATE
+ $<${is_msvc_fe}:/arch:AVX2>
+ $<${is_clangcl}:-mavx2 -mpopcnt -mf16c>
+ $<${is_gnu_fe}:-mavx2 -mpopcnt -mf16c>
+- $<${is_gnu_fe}:-Wno-unused-command-line-argument>)
++ )
+ endif()
+
+ # Non-invariant builds enable us to loosen the compiler constraints on
+@@ -380,20 +373,13 @@ string(CONCAT EXTERNAL_CXX_FLAGS
+ " $<${is_gnu_fe}: -Wno-old-style-cast>"
+ " $<${is_gnu_fe}: -Wno-double-promotion>"
+ " $<${is_gnu_fe}: -Wno-zero-as-null-pointer-constant>"
+- " $<${is_gnu_fe}: -Wno-disabled-macro-expansion>"
+- " $<${is_gnu_fe}: -Wno-reserved-id-macro>"
+- " $<${is_gnu_fe}: -Wno-extra-semi-stmt>"
+ " $<${is_gnu_fe}: -Wno-implicit-fallthrough>"
+- " $<${is_gnu_fe}: -Wno-tautological-type-limit-compare>"
+ " $<${is_gnu_fe}: -Wno-cast-qual>"
+- " $<${is_gnu_fe}: -Wno-reserved-identifier>"
+ " $<${is_clang}: -Wno-missing-prototypes>"
+ " $<${is_gnu_fe}: -Wno-missing-field-initializers>"
+ " $<${is_gnu_fe}: -Wno-suggest-override>"
+- " $<${is_gnu_fe}: -Wno-used-but-marked-unused>"
+ " $<${is_gnu_fe}: -Wno-noexcept-type>"
+- " $<${is_gnu_fe}: -Wno-comma>"
+- " $<${is_gnu_fe}: -Wno-c99-extensions>")
++)
+
+ set_source_files_properties(astcenccli_image_external.cpp
+ PROPERTIES
diff --git a/PKGBUILD b/PKGBUILD
index 173e27f75acd..f99d777ade0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.7.0
+pkgver=4.8.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
url='https://github.com/ARM-software/astc-encoder/'
-license=('Apache')
+license=('Apache-2.0')
depends=('gcc-libs')
makedepends=('git' 'cmake' 'python')
source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
- 'git+https://github.com/google/googletest.git')
-sha256sums=('SKIP'
- 'SKIP')
+ 'git+https://github.com/google/googletest.git'
+ '010-astc-encoder-remove-werror.patch'
+ '020-astc-encoder-remove-flags-unsupported-by-gcc14.patch')
+sha256sums=('7f0858835a9ec611eaf05c6a095605378705ba8ad9ef6274b69ffe5e7755dc48'
+ 'SKIP'
+ 'fff998bd640aede9584b68d5f9cef9de785deef56ffc6d10fda6d112a6e649a2'
+ '9d5773a29c2110fb9137471cd525701ddf95a7990a27e40b7d3e2cfd69719812')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder -c protocol.file.allow='always' submodule update
+
+ patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-remove-werror.patch"
+ patch -d astc-encoder -Np1 -i "${srcdir}/020-astc-encoder-remove-flags-unsupported-by-gcc14.patch"
}
build() {