summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-06-21 21:27:28 -0300
committerDaniel Bermond2023-06-21 21:27:28 -0300
commitb21513658b0e592eb0c6b4cbf716dab462617346 (patch)
tree9559159508cf08931e09fe9146943663e73f56b4
parentead88815cea1c994589db59130f2819b9d4f3ff7 (diff)
downloadaur-astc-encoder-git.tar.gz
Update cmake commands
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74f7486d35f5..8d4b2a09840a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder-git
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard (git version)
- pkgver = 4.4.0.r3.gc9217e1
+ pkgver = 4.5.0.r0.g770ef22
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 01d8fbedd992..a305729b3418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dario Ostuni <another.code.996@gmail.com>
pkgname=astc-encoder-git
-pkgver=4.4.0.r3.gc9217e1
+pkgver=4.5.0.r0.g770ef22
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard (git version)'
arch=('x86_64')
@@ -32,11 +32,10 @@ build() {
-G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DSHAREDLIB:BOOL='ON' \
- -DISA_AVX2:BOOL='ON' \
- -DISA_SSE41:BOOL='ON' \
- -DISA_SSE2:BOOL='ON' \
- -DUNITTEST:BOOL='ON' \
+ -DASTCENC_SHAREDLIB:BOOL='ON' \
+ -DASTCENC_ISA_AVX2:BOOL='ON' \
+ -DASTCENC_ISA_SSE41:BOOL='ON' \
+ -DASTCENC_ISA_SSE2:BOOL='ON' \
-Wno-dev
cmake --build build
}
@@ -50,5 +49,4 @@ package() {
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
ln -s libastcenc-sse2-shared.so "${pkgdir}/usr/lib/libastcenc.so"
- rm "${pkgdir}/usr/bin"/test-unit*
}