summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-10 14:52:48 -0300
committerDaniel Bermond2022-11-10 14:52:48 -0300
commit2af845bb191e42ddd2a0ed5ec0026e4020b8cc3a (patch)
treee23ba43b8048efc5731b34598f6d2161ddc08b51
parente9c261dba4c38a856e1b08b5d6f02a0aa5cc4715 (diff)
downloadaur-2af845bb191e42ddd2a0ed5ec0026e4020b8cc3a.tar.gz
Fix git submodule
-rw-r--r--.SRCINFO4
-rw-r--r--010-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4df79e900df0..d190e0c07bb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder-git
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard (git version)
- pkgver = 4.0.0.r1.g9cfb30b
+ pkgver = 4.2.0.r0.g3103c70
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -16,6 +16,6 @@ pkgbase = astc-encoder-git
source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210
+ sha256sums = de18c29f9a12f00562487e73d255135184bb74cd0ebacd0576363655e7071e55
pkgname = astc-encoder-git
diff --git a/010-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
index a1efe29e5c15..89b87911ba69 100644
--- a/010-astc-encoder-use-shared-library.patch
+++ b/010-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -310,16 +314,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -302,16 +306,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -64,7 +64,7 @@
PRIVATE
$<$<CXX_COMPILER_ID:MSVC>:/W3>)
-@@ -330,9 +334,10 @@ if(${CLI})
+@@ -322,9 +326,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index 31d541dedd1e..f790aa5668c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dario Ostuni <another.code.996@gmail.com>
pkgname=astc-encoder-git
-pkgver=4.0.0.r1.g9cfb30b
+pkgver=4.2.0.r0.g3103c70
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard (git version)'
arch=('x86_64')
@@ -17,12 +17,12 @@ source=('git+https://github.com/ARM-software/astc-encoder.git#branch=main'
'010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- 'dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210')
+ 'de18c29f9a12f00562487e73d255135184bb74cd0ebacd0576363655e7071e55')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
- git -C astc-encoder submodule update
+ git -C astc-encoder -c protocol.file.allow='always' submodule update
patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}