summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2016-04-08 13:58:21 +0200
committerDario Ostuni2016-04-08 13:58:21 +0200
commit39307c16b798053d74ef3690feadca33f70ed09a (patch)
tree1227d6ed77acc4545706fedd681dc75d282ac4ce
downloadaur-39307c16b798053d74ef3690feadca33f70ed09a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6887ccec4e40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Apr 8 11:58:17 UTC 2016
+pkgbase = astc-encoder-git
+ pkgdesc = An ASTC (Adaptive Scalable Texture Compression) encoder and decoder
+ pkgver = r6.437f242
+ pkgrel = 1
+ url = https://github.com/ARM-software/astc-encoder
+ arch = i686
+ arch = x86_64
+ license = CUSTOM
+ depends = openexr
+ source = git+https://github.com/ARM-software/astc-encoder.git
+ sha256sums = SKIP
+
+pkgname = astc-encoder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fc4033fd6c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+pkgname=astc-encoder-git
+pkgver=r6.437f242
+pkgrel=1
+pkgdesc="An ASTC (Adaptive Scalable Texture Compression) encoder and decoder"
+arch=('i686' 'x86_64')
+url="https://github.com/ARM-software/astc-encoder"
+license=('CUSTOM')
+depends=('openexr')
+options=()
+source=("git+https://github.com/ARM-software/astc-encoder.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/astc-encoder"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/astc-encoder/Source"
+ make
+ c++ exr_to_htga.cpp $(pkg-config --cflags --libs OpenEXR) -o exr_to_htga
+}
+
+package() {
+ cd "$srcdir/astc-encoder/Source"
+ install -Dm755 astcenc "$pkgdir/usr/bin/astcenc"
+ install -Dm755 exr_to_htga "$pkgdir/usr/bin/exr_to_htga"
+ install -Dm644 ../license.txt "$pkgdir/usr/share/licenses/astc-encoder-git/LICENSE"
+}