summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2016-08-23 03:27:42 +0200
committerDario Ostuni2016-08-23 03:27:42 +0200
commit5f2ae00726bfa850ccaa75ff41abda097ad06560 (patch)
tree723e7a0a08b145d9ada23184c1f0dc59c3809e4e
parent39307c16b798053d74ef3690feadca33f70ed09a (diff)
downloadaur-5f2ae00726bfa850ccaa75ff41abda097ad06560.tar.gz
Compilation is broken with gcc 6, using clang
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6887ccec4e40..241f22c83c2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Apr 8 11:58:17 UTC 2016
+# Tue Aug 23 01:27:38 UTC 2016
pkgbase = astc-encoder-git
pkgdesc = An ASTC (Adaptive Scalable Texture Compression) encoder and decoder
- pkgver = r6.437f242
+ pkgver = r8.a1b3a96
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder
arch = i686
arch = x86_64
license = CUSTOM
+ makedepends = clang
depends = openexr
source = git+https://github.com/ARM-software/astc-encoder.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3fc4033fd6c0..20f9bba00ead 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Dario Ostuni <another.code.996@gmail.com>
pkgname=astc-encoder-git
-pkgver=r6.437f242
+pkgver=r8.a1b3a96
pkgrel=1
pkgdesc="An ASTC (Adaptive Scalable Texture Compression) encoder and decoder"
arch=('i686' 'x86_64')
url="https://github.com/ARM-software/astc-encoder"
license=('CUSTOM')
depends=('openexr')
+makedepends=('clang')
options=()
source=("git+https://github.com/ARM-software/astc-encoder.git")
sha256sums=('SKIP')
@@ -18,8 +19,9 @@ pkgver() {
build() {
cd "$srcdir/astc-encoder/Source"
+ sed -i -- 's/g++/clang++/g' Makefile
make
- c++ exr_to_htga.cpp $(pkg-config --cflags --libs OpenEXR) -o exr_to_htga
+ clang++++ exr_to_htga.cpp $(pkg-config --cflags --libs OpenEXR) -o exr_to_htga
}
package() {