summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-22 16:16:51 -0300
committerDaniel Bermond2022-07-22 16:16:51 -0300
commite9c261dba4c38a856e1b08b5d6f02a0aa5cc4715 (patch)
tree9b99f9a079001d05b0a9ebeedb3b1d03777a28bc
parentbed6291e4d676c9ed1a15dfce621ff8105973fd7 (diff)
downloadaur-e9c261dba4c38a856e1b08b5d6f02a0aa5cc4715.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO8
-rw-r--r--010-astc-encoder-fix-install.patch19
-rw-r--r--010-astc-encoder-use-shared-library.patch (renamed from 020-astc-encoder-use-shared-library.patch)14
-rw-r--r--PKGBUILD12
4 files changed, 19 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7a0d4f2f90d..4df79e900df0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder-git
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard (git version)
- pkgver = 3.5.r0.g7e2a81e
+ pkgver = 4.0.0.r1.g9cfb30b
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -13,11 +13,9 @@ pkgbase = astc-encoder-git
conflicts = astc-encoder
source = git+https://github.com/ARM-software/astc-encoder.git#branch=main
source = git+https://github.com/google/googletest.git
- source = 010-astc-encoder-fix-install.patch
- source = 020-astc-encoder-use-shared-library.patch
+ source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92
- sha256sums = 5507d79c2033b4258eed77e1498cf835a57b7a9d4b898100c4b1ceff2b230f73
+ sha256sums = dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210
pkgname = astc-encoder-git
diff --git a/010-astc-encoder-fix-install.patch b/010-astc-encoder-fix-install.patch
deleted file mode 100644
index 2c504feff9c4..000000000000
--- a/010-astc-encoder-fix-install.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -30,7 +30,7 @@ set(CMAKE_CXX_STANDARD 14)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
- set(CMAKE_CXX_EXTENSIONS OFF)
- set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
--set(PACKAGE_ROOT astcenc)
-+set(PACKAGE_ROOT bin)
-
- include(CTest)
-
---- a/Source/UnitTest/cmake_core.cmake
-+++ b/Source/UnitTest/cmake_core.cmake
-@@ -135,4 +135,4 @@ target_link_libraries(${ASTC_TEST}
- add_test(NAME ${ASTC_TEST}
- COMMAND ${ASTC_TEST})
-
--install(TARGETS ${ASTC_TEST} DESTINATION ${PACKAGE_ROOT})
-+
diff --git a/020-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
index 06cf90ce1fe1..a1efe29e5c15 100644
--- a/020-astc-encoder-use-shared-library.patch
+++ b/010-astc-encoder-use-shared-library.patch
@@ -43,20 +43,28 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -266,10 +270,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -310,16 +314,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
-astcenc_set_properties(${ASTC_TARGET}-static)
+astcenc_set_properties(${ASTC_TARGET})
+- target_compile_options(${ASTC_TARGET}-static
++ target_compile_options(${ASTC_TARGET}
+ PRIVATE
+ $<$<CXX_COMPILER_ID:MSVC>:/W4>)
+
if(${CLI})
- astcenc_set_properties(${ASTC_TARGET})
+ astcenc_set_properties(${ASTC_TARGET}-bin)
- string(TIMESTAMP astcencoder_YEAR "%Y")
+- target_compile_options(${ASTC_TARGET}
++ target_compile_options(${ASTC_TARGET}-bin
+ PRIVATE
+ $<$<CXX_COMPILER_ID:MSVC>:/W3>)
-@@ -278,9 +282,10 @@ if(${CLI})
+@@ -330,9 +334,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index 730845655d70..31d541dedd1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dario Ostuni <another.code.996@gmail.com>
pkgname=astc-encoder-git
-pkgver=3.5.r0.g7e2a81e
+pkgver=4.0.0.r1.g9cfb30b
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard (git version)'
arch=('x86_64')
@@ -14,19 +14,16 @@ provides=('astc-encoder')
conflicts=('astc-encoder')
source=('git+https://github.com/ARM-software/astc-encoder.git#branch=main'
'git+https://github.com/google/googletest.git'
- '010-astc-encoder-fix-install.patch'
- '020-astc-encoder-use-shared-library.patch')
+ '010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- '5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
- '5507d79c2033b4258eed77e1498cf835a57b7a9d4b898100c4b1ceff2b230f73')
+ 'dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder submodule update
- patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-fix-install.patch"
- patch -d astc-encoder -Np1 -i "${srcdir}/020-astc-encoder-use-shared-library.patch"
+ patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}
pkgver() {
@@ -54,4 +51,5 @@ package() {
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
ln -s libastcenc-sse2.so "${pkgdir}/usr/lib/libastcenc.so"
+ rm "${pkgdir}/usr/bin"/test-unit*
}