summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Goins2023-09-29 16:24:09 -0400
committerJoshua Goins2023-09-29 16:24:09 -0400
commitc8f039554945aa280963e530841d2c1b04c7dd01 (patch)
tree2030db6e4492b5d7c2c9aeb61929d79017db3b13
parent88a8ecc961b8412a44cbac0cd12917a7e209c706 (diff)
downloadaur-astra-launcher.tar.gz
Update to 0.4.2
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD4
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 981141d8b3b6..33f66aa1f557 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = astra-launcher
- pkgdesc = Cross-platform FFXIV launcher
- pkgver = 0.4.1
- pkgrel = 2
- url = https://git.sr.ht/~redstrate/astra
- arch = x86_64
- license = GPL3
- makedepends = cmake
- makedepends = git
- depends = qt5-base
- depends = quazip-qt5
- depends = qtkeychain-qt5
- depends = libxcomposite
- depends = unshield
- depends = fmt
- depends = pugixml
- source = astra-launcher-0.4.1::https://xiv.zone/distrib/astra/0.4.1/astra-source.tar.gz
- sha256sums = c25e84180485639989bb0bbd073b5a52412f45e0c36884963a1a7a3a136266f2
+ pkgdesc = Cross-platform FFXIV launcher
+ pkgver = 0.4.2
+ pkgrel = 2
+ url = https://git.sr.ht/~redstrate/astra
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ depends = quazip-qt5
+ depends = qtkeychain-qt5
+ depends = libxcomposite
+ depends = unshield
+ depends = fmt
+ depends = pugixml
+ source = astra-launcher-0.4.2::https://xiv.zone/distrib/astra/0.4.2/astra-source.tar.gz
+ sha256sums = 27e182e0710cd75b5e0697f40e13c3b0013b0b28ecb93a5357a073b2a7090fc4
pkgname = astra-launcher
diff --git a/PKGBUILD b/PKGBUILD
index d51eaff1486f..70d257940a2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: redstrate <josh@redstrate.com>
pkgname=astra-launcher
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=2
pkgdesc="Cross-platform FFXIV launcher"
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite' 'unshield' 'fmt' 'pugixml') # this x11 dependency is going to be removed in a future release
makedepends=('cmake' 'git') # git is needed for some cmake operations
source=("$pkgname-$pkgver::https://xiv.zone/distrib/astra/$pkgver/astra-source.tar.gz") # sorry about the -beta on tags, this will be removed in the near future
-sha256sums=('c25e84180485639989bb0bbd073b5a52412f45e0c36884963a1a7a3a136266f2')
+sha256sums=('27e182e0710cd75b5e0697f40e13c3b0013b0b28ecb93a5357a073b2a7090fc4')
build() {
cmake -DCMAKE_BUILD_TYPE=Release -DUSE_OWN_LIBRARIES=OFF ./