summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Goins2022-05-02 13:10:43 -0400
committerJoshua Goins2022-05-02 13:10:43 -0400
commit6a8bab5ddd0bc0577c3ef59c28374cf5d1bbc972 (patch)
treee7185e6a4a68fd9ba0f65a496ec695b2fe9b2606
parentb7e5dcc6ec6285013eaacfcbd25f19849f64ae07 (diff)
downloadaur-6a8bab5ddd0bc0577c3ef59c28374cf5d1bbc972.tar.gz
Update to 0.4.0 release, add new dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49a55494e71f..c79a324536f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = astra-launcher
- pkgdesc = A cross-platform FFXIV launcher
- pkgver = 0.3.1
+ pkgdesc = Cross-platform FFXIV launcher
+ pkgver = 0.4.0
pkgrel = 1
url = https://git.sr.ht/~redstrate/astra
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = git
depends = qt5-base
depends = quazip-qt5
depends = qtkeychain-qt5
depends = libxcomposite
- source = astra-launcher-0.3.1::https://git.sr.ht/~redstrate/astra/archive/v0.3.1-beta.tar.gz
- sha256sums = 3816d6b69faa98b4b7ed0f2dbcb5922b6d8e5b7cb9555ff0a4dfa51372fa0d69
+ depends = unshield
+ depends = fmt
+ depends = pugixml
+ source = astra-launcher-0.4.0::https://xiv.zone/distrib/astra/0.4.0/astra-source.tar.gz
+ sha256sums = 6484f57ca563514daf176a771a7374e2bf1441a3604741899e2b0a7270698a80
pkgname = astra-launcher
diff --git a/PKGBUILD b/PKGBUILD
index 873152495e13..308c301d6c8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: redstrate <josh@redstrate.com>
pkgname=astra-launcher
-pkgver=0.3.1
+pkgver=0.4.0
pkgrel=1
-pkgdesc="A cross-platform FFXIV launcher"
+pkgdesc="Cross-platform FFXIV launcher"
arch=('x86_64')
url="https://git.sr.ht/~redstrate/astra"
license=('GPL3')
-depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite') # this x11 dependency is going to be removed in a future release
-makedepends=('cmake')
-source=("$pkgname-$pkgver::https://git.sr.ht/~redstrate/astra/archive/v$pkgver-beta.tar.gz") # sorry about the -beta on tags, this will be removed in the near future
-sha256sums=('3816d6b69faa98b4b7ed0f2dbcb5922b6d8e5b7cb9555ff0a4dfa51372fa0d69')
+depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite' 'unshield' 'fmt' 'pugixml') # this x11 dependency is going to be removed in a future release
+makedepends=('cmake' 'git') # git is needed for some cmake operations
+source=("$pkgname-$pkgver::https://xiv.zone/distrib/astra/$pkgver/astra-source.tar.gz") # sorry about the -beta on tags, this will be removed in the near future
+sha256sums=('6484f57ca563514daf176a771a7374e2bf1441a3604741899e2b0a7270698a80')
build() {
- cd "astra-v$pkgver-beta"
- cmake -DCMAKE_BUILD_TYPE=Release ./
+ cmake -DCMAKE_BUILD_TYPE=Release -DUSE_OWN_LIBRARIES=OFF ./
cmake --build ./
}
package() {
- cd "astra-v$pkgver-beta"
cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
make install
find "$pkgdir" -type d -name ".git" -exec rm -r '{}' +