summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Goins2022-03-30 13:34:08 -0400
committerJoshua Goins2022-03-30 13:34:08 -0400
commit834320c87bfb9b00222b21a543c9c172570930fe (patch)
tree81209485c30ec5b6efd0f239af8bd1d5ee8d0db6
parentfefe86b705363b853ef4bca915c3f2b36230557b (diff)
downloadaur-834320c87bfb9b00222b21a543c9c172570930fe.tar.gz
Handle libxiv submodule
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd77f2c1152f..800854d1b07f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astra-launcher-git
pkgdesc = A cross-platform FFXIV launcher
- pkgver = 0.3.1.beta.r25.gc460f2d
+ pkgver = 0.3.1.beta.r46.g7ee2e5a
pkgrel = 1
url = https://git.sr.ht/~redstrate/astra
arch = x86_64
@@ -14,6 +14,8 @@ pkgbase = astra-launcher-git
provides = astra-launcher
conflicts = astra-launcher
source = astra-git::git+https://git.sr.ht/~redstrate/astra
+ source = libxiv-git::git+https://git.sr.ht/~redstrate/libxiv
+ md5sums = SKIP
md5sums = SKIP
pkgname = astra-launcher-git
diff --git a/PKGBUILD b/PKGBUILD
index df97eb0667ef..89a7840a864d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: redstrate <josh@redstrate.com>
pkgname=astra-launcher-git
-pkgver=0.3.1.beta.r25.gc460f2d
+pkgver=0.3.1.beta.r46.g7ee2e5a
pkgrel=1
pkgdesc="A cross-platform FFXIV launcher"
arch=('x86_64')
@@ -11,16 +11,19 @@ depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite') # this x11 de
makedepends=('git' 'cmake')
provides=('astra-launcher')
conflicts=('astra-launcher')
-source=('astra-git::git+https://git.sr.ht/~redstrate/astra')
-md5sums=('SKIP')
+source=('astra-git::git+https://git.sr.ht/~redstrate/astra' 'libxiv-git::git+https://git.sr.ht/~redstrate/libxiv')
+md5sums=('SKIP' 'SKIP')
pkgver() {
- cd "astra-git"
+ cd "astra-git"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "astra-git"
+ cd "astra-git"
+ git submodule init
+ git config submodule.'external/libxiv'.url "$srcdir/libxiv-git"
+ git submodule update
cmake -DCMAKE_BUILD_TYPE=Release ./
cmake --build ./
}