summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Goins2022-05-02 13:12:57 -0400
committerJoshua Goins2022-05-02 13:12:57 -0400
commit9389949c6ebe343985f71f8b5ade1bf9eb3b60f0 (patch)
tree6555a361404f2e8d1cdfd4836cca427e0a1232ec
parent834320c87bfb9b00222b21a543c9c172570930fe (diff)
downloadaur-9389949c6ebe343985f71f8b5ade1bf9eb3b60f0.tar.gz
Update dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 800854d1b07f..f2e0ac1fdcea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astra-launcher-git
- pkgdesc = A cross-platform FFXIV launcher
- pkgver = 0.3.1.beta.r46.g7ee2e5a
+ pkgdesc = Cross-platform FFXIV launcher (git version)
+ pkgver = 0.4.0.r0.g7cfa2e4
pkgrel = 1
url = https://git.sr.ht/~redstrate/astra
arch = x86_64
@@ -11,6 +11,9 @@ pkgbase = astra-launcher-git
depends = quazip-qt5
depends = qtkeychain-qt5
depends = libxcomposite
+ depends = unshield
+ depends = fmt
+ depends = pugixml
provides = astra-launcher
conflicts = astra-launcher
source = astra-git::git+https://git.sr.ht/~redstrate/astra
diff --git a/PKGBUILD b/PKGBUILD
index 89a7840a864d..365225f0a146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: redstrate <josh@redstrate.com>
pkgname=astra-launcher-git
-pkgver=0.3.1.beta.r46.g7ee2e5a
+pkgver=0.4.0.r0.g7cfa2e4
pkgrel=1
-pkgdesc="A cross-platform FFXIV launcher"
+pkgdesc="Cross-platform FFXIV launcher (git version)"
arch=('x86_64')
url="https://git.sr.ht/~redstrate/astra"
license=('GPL3')
-depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite') # this x11 dependency is going to be removed in a future release
+depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite' 'unshield' 'fmt' 'pugixml') # this x11 dependency is going to be removed in a future release
makedepends=('git' 'cmake')
provides=('astra-launcher')
conflicts=('astra-launcher')
@@ -24,7 +24,7 @@ build() {
git submodule init
git config submodule.'external/libxiv'.url "$srcdir/libxiv-git"
git submodule update
- cmake -DCMAKE_BUILD_TYPE=Release ./
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebugInfo -DUSE_OWN_LIBRARIES=OFF ./
cmake --build ./
}