summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Goins2023-09-29 16:35:26 -0400
committerJoshua Goins2023-09-29 16:35:26 -0400
commitc9306a091fa26ae5478fd2331493f2fb22120968 (patch)
treee3cdd985d0092affb7777d6eb22894a8c8b85086
parent9389949c6ebe343985f71f8b5ade1bf9eb3b60f0 (diff)
downloadaur-c9306a091fa26ae5478fd2331493f2fb22120968.tar.gz
Fix build and update dependencies
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD15
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2e0ac1fdcea..9a2c50c26ba6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,32 @@
pkgbase = astra-launcher-git
pkgdesc = Cross-platform FFXIV launcher (git version)
- pkgver = 0.4.0.r0.g7cfa2e4
+ pkgver = 0.4.0.r241.g0ed554d
pkgrel = 1
url = https://git.sr.ht/~redstrate/astra
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
- depends = qt5-base
- depends = quazip-qt5
- depends = qtkeychain-qt5
- depends = libxcomposite
+ depends = qt6-base
+ depends = qt6-declarative
+ depends = qt6-webview
+ depends = kirigami2
+ depends = kconfig
+ depends = kcoreaddons
+ depends = kirigami-addons
+ depends = quazip-qt6
+ depends = qtkeychain-qt6
depends = unshield
- depends = fmt
- depends = pugixml
+ depends = qcoro-qt6
+ depends = rust
+ depends = corrosion
+ depends = extra-cmake-modules
provides = astra-launcher
conflicts = astra-launcher
source = astra-git::git+https://git.sr.ht/~redstrate/astra
- source = libxiv-git::git+https://git.sr.ht/~redstrate/libxiv
+ source = libcotp-git::git+https://github.com/redstrate/libcotp.git
+ source = libphysis-git::git+https://git.sr.ht/~redstrate/libphysis
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 365225f0a146..a5d351516870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: redstrate <josh@redstrate.com>
pkgname=astra-launcher-git
-pkgver=0.4.0.r0.g7cfa2e4
+pkgver=0.4.0.r241.g0ed554d
pkgrel=1
pkgdesc="Cross-platform FFXIV launcher (git version)"
arch=('x86_64')
url="https://git.sr.ht/~redstrate/astra"
license=('GPL3')
-depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite' 'unshield' 'fmt' 'pugixml') # this x11 dependency is going to be removed in a future release
+depends=('qt6-base' 'qt6-declarative' 'qt6-webview' 'kirigami2' 'kconfig' 'kcoreaddons' 'kirigami-addons' 'quazip-qt6' 'qtkeychain-qt6' 'unshield' 'qcoro-qt6' 'rust' 'corrosion' 'extra-cmake-modules')
makedepends=('git' 'cmake')
provides=('astra-launcher')
conflicts=('astra-launcher')
-source=('astra-git::git+https://git.sr.ht/~redstrate/astra' 'libxiv-git::git+https://git.sr.ht/~redstrate/libxiv')
-md5sums=('SKIP' 'SKIP')
+source=('astra-git::git+https://git.sr.ht/~redstrate/astra' 'libcotp-git::git+https://github.com/redstrate/libcotp.git' 'libphysis-git::git+https://git.sr.ht/~redstrate/libphysis')
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "astra-git"
@@ -22,9 +22,10 @@ pkgver() {
build() {
cd "astra-git"
git submodule init
- git config submodule.'external/libxiv'.url "$srcdir/libxiv-git"
- git submodule update
- cmake -DCMAKE_BUILD_TYPE=RelWithDebugInfo -DUSE_OWN_LIBRARIES=OFF ./
+ git config submodule.'external/libcotp'.url "$srcdir/libcotp-git"
+ git config submodule.'external/libphysis'.url "$srcdir/libphysis-git"
+ git -c protocol.file.allow=always submodule update
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebugInfo -DQT_MAJOR_VERSION=6 ./
cmake --build ./
}