summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Goins2022-03-16 14:08:45 -0400
committerJoshua Goins2022-03-16 14:08:45 -0400
commitfefe86b705363b853ef4bca915c3f2b36230557b (patch)
tree2b4c47c0ab312e4cd988eb7e7cdb5045fe9998ff
parente1ad86d5c1324185d6ab1b3a20c7c7c5421ea994 (diff)
downloadaur-fefe86b705363b853ef4bca915c3f2b36230557b.tar.gz
Merging user patches
Thank you to FabioLolix for submitting the patches!
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb2a8c4e5613..dd77f2c1152f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astra-launcher-git
pkgdesc = A cross-platform FFXIV launcher
- pkgver = v0.3.1.beta.r21.g94a740a
+ pkgver = 0.3.1.beta.r25.gc460f2d
pkgrel = 1
url = https://git.sr.ht/~redstrate/astra
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 0f31b7ebeec7..df97eb0667ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: redstrate <josh@redstrate.com>
+
pkgname=astra-launcher-git
-pkgver=v0.3.1.beta.r21.g94a740a
+pkgver=0.3.1.beta.r25.gc460f2d
pkgrel=1
pkgdesc="A cross-platform FFXIV launcher"
arch=('x86_64')
@@ -8,7 +9,6 @@ url="https://git.sr.ht/~redstrate/astra"
license=('GPL3')
depends=('qt5-base' 'quazip-qt5' 'qtkeychain-qt5' 'libxcomposite') # this x11 dependency is going to be removed in a future release
makedepends=('git' 'cmake')
-install=
provides=('astra-launcher')
conflicts=('astra-launcher')
source=('astra-git::git+https://git.sr.ht/~redstrate/astra')
@@ -16,10 +16,7 @@ md5sums=('SKIP')
pkgver() {
cd "astra-git"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -32,6 +29,5 @@ package() {
cd "astra-git"
cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
make install
- find "$pkgdir" -type d -name ".git" -exec rm -r '{}' +
}