summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gerhard Martinussen2018-05-04 23:34:34 +0200
committerJakob Gerhard Martinussen2018-05-04 23:34:34 +0200
commitd2fd0a455e07b2639ef4158e7f47369b9cff07c3 (patch)
tree2d7539598488b7d8ae924a3f92e11a7f1978e1b2
parent7757245739c8f866c5a10c7352a48518bf75240b (diff)
downloadaur-d2fd0a455e07b2639ef4158e7f47369b9cff07c3.tar.gz
Specify all dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06867744a668..d0aeb9b6203e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,13 @@ pkgbase = astrality-git
makedepends = git
makedepends = sed
depends = python
+ depends = python-mypy_extensions
+ depends = python-astral
+ depends = python-jinja
+ depends = python-yaml
+ depends = python-requests
+ depends = python-watchdog-git
optdepends = libyaml: faster YAML config parsing
- provides = astrality
- conflicts = astrality
source = astrality::git+https://github.com/JakobGM/astrality.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ea470a8b2c0b..5f318dc28bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,18 @@ url='https://astrality.readthedocs.io'
arch=('any')
license=('MIT')
-depends=('python')
+depends=(
+ 'python'
+ 'python-mypy_extensions'
+ 'python-astral'
+ 'python-jinja'
+ 'python-yaml'
+ 'python-requests'
+ 'python-watchdog-git'
+)
makedepends=('python-setuptools' 'git' 'sed')
optdepends=('libyaml: faster YAML config parsing')
-provides=('astrality')
-conflicts=('astrality')
-
source=('astrality::git+https://github.com/JakobGM/astrality.git')
sha256sums=('SKIP')