summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Černý2022-07-02 10:38:29 +0200
committerJan Černý2022-07-02 10:38:29 +0200
commit7e36de49878daf9c29bd781673bcee0647ec9091 (patch)
tree3b7c6d7675f76dba4232405923b8286c51c4a9fd
parentf993931e3b225d37fe473c2349cae5b7779cf95a (diff)
downloadaur-7e36de49878daf9c29bd781673bcee0647ec9091.tar.gz
Upbdated to 1.5.0.0
-rw-r--r--PKGBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7eea83d1f3e..ce69b34cd9bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=astrodmx-capture
-pkgver=1.4.2.1
+pkgver=1.5.0.0
pkgrel=1
pkgdesc="AstroDMx Capture Astronomical Imaging"
arch=('x86_64')
@@ -16,10 +16,10 @@ install=$pkgname.install
# The Author, Nicola, is now copying new releases into both the `current` and `old` folders so that we
# can maintain a constant path the file. Hopefully this will allow us to continue installing older versions
# without breakage after a new version is released. Thanks Nicola!
-source=("https://www.astrodmx-capture.org.uk/downloads/astrodmx/old/x86-64/astrodmx-capture_${pkgver}_x86-64-manual.tar.gz")
-sha256sums=("a0ce7c38fc57fd75bb5ccd1bf4d6f7c0007511d97d9e7cab769078c421cc67dc")
+source=("https://www.astrodmx-capture.org.uk/downloads/astrodmx/current/x86-64/astrodmx-capture_${pkgver}_x86-64-manual.tar.gz")
+sha256sums=("aa3585edc44aa79a52e5bbb6a6b09ad81c6796ab494319fdd086f92289aa3ffb")
-_instdir="/usr/local/AstroDMx_Capture"
+_instdir="/opt/AstroDMx-Capture"
_prefix="AstroDMx-${pkgver}-manual"
package() {
@@ -27,7 +27,19 @@ package() {
mkdir -p "${pkgdir}${_instdir}"
# copy over the linux 64 bit files
- cp --recursive ${_prefix}/usr/local/AstroDMx_Capture/* "${pkgdir}${_instdir}"
+ cp --recursive ${_prefix}/opt/AstroDMx-Capture/* "${pkgdir}${_instdir}"
+
+ # remove broken libs (see: https://www.astrodmx-capture.org.uk/astrodmx-capture-known-issues/)
+ rm "${pkgdir}${_instdir}/lib/libstdc++.so.6"
+ rm "${pkgdir}${_instdir}/lib/libgcc_s.so.1"
+
+ # add xdg menu
+ mkdir -p ${pkgdir}/etc/xdg/menus/applications-merged/
+ cp "${_prefix}/etc/xdg/menus/applications-merged/astrodmx.menu" "${pkgdir}/etc/xdg/menus/applications-merged/"
+
+ # copy usr share
+ mkdir -p "${pkgdir}/usr/share/"
+ cp -r ${_prefix}/usr/share/* "${pkgdir}/usr/share/"
# copy over the udev rules
mkdir -p "${pkgdir}/etc/udev/rules.d"