summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Roll2020-09-05 18:23:44 +1000
committerAshley Roll2020-09-05 18:23:44 +1000
commit866970aaf8a81294e1f2c6c9e0fdfb82a6550860 (patch)
treec4c33b556c7f8cfcee76091503daa5baa05d0a47
parent012166ef2b2edfde7bf6b4aa1c2d61b13b651384 (diff)
downloadaur-866970aaf8a81294e1f2c6c9e0fdfb82a6550860.tar.gz
Updated to version 0.78.3
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c33bee190343..eadb2403c979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = astrodmx-capture
pkgdesc = AstroDMx Capture Astronomical Imaging
- pkgver = 0.68.1
+ pkgver = 0.78.3
pkgrel = 1
url = https://www.linux-astro-imaging.uk/
install = astrodmx-capture.install
arch = x86_64
license = custom
options = !strip
- source = https://www.linux-astro-imaging.uk/sites/downloads/astrodmx_capture-0.68.1-manual-x86_64.tar.gz
- sha256sums = 31f66b5998b76d8853061a465d8aef53145d36aad27cfe16bb13624259c8e0ea
+ source = https://www.linux-astro-imaging.uk/sites/downloads/astrodmx_capture-0.78.3-manual-x86_64.tar.gz
+ sha256sums = a4bd110c6fb0b7371491ed3d615894edf8ddf927723bad8e2fe497fc8c748184
pkgname = astrodmx-capture
diff --git a/.gitignore b/.gitignore
index b53c6dff1211..fcd31addb880 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ src/
*.zip
*.tar.xz
*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 8ddb0606d643..3a91e1016f3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ashely Roll <ash at digitalnemesis dot com>
pkgname=astrodmx-capture
-pkgver=0.68.1
+pkgver=0.78.3
pkgrel=1
pkgdesc="AstroDMx Capture Astronomical Imaging"
arch=('x86_64')
@@ -12,26 +12,29 @@ license=(custom)
options=(!strip)
install=$pkgname.install
-source=("https://www.linux-astro-imaging.uk/sites/downloads/astrodmx_capture-0.68.1-manual-x86_64.tar.gz")
-sha256sums=("31f66b5998b76d8853061a465d8aef53145d36aad27cfe16bb13624259c8e0ea")
+source=("https://www.linux-astro-imaging.uk/sites/downloads/astrodmx_capture-${pkgver}-manual-x86_64.tar.gz")
+sha256sums=("a4bd110c6fb0b7371491ed3d615894edf8ddf927723bad8e2fe497fc8c748184")
-_instdir="/usr/local/AstroDMx_Cpature"
+_instdir="/usr/local/AstroDMx_Capture"
+_prefix="x86-64-2.29"
package() {
# create the desitination folder
mkdir -p "${pkgdir}${_instdir}"
# copy over the linux 64 bit files
- cp --recursive x86_64/usr/local/AstroDMx_Capture/* "${pkgdir}${_instdir}"
+ cp --recursive ${_prefix}/usr/local/AstroDMx_Capture/* "${pkgdir}${_instdir}"
# copy over the udev rules
mkdir -p "${pkgdir}/etc/udev/rules.d"
- cp x86_64/etc/udev/rules.d/* "${pkgdir}/etc/udev/rules.d"
+ cp ${_prefix}/etc/udev/rules.d/* "${pkgdir}/etc/udev/rules.d"
# create a profile file to add an alias for astrodmx
# this is needed because the application has to be launced from the bin folder
# to correctly work, so we can't just add the path. sigh.
+ # Update V0.78.3: Now have to start with launcher.sh, this does a cd, so will continue
+ # to wrap with pushd/popd to not mess up local path
mkdir -p "${pkgdir}/etc/profile.d"
- echo "alias astrodmx=\"pushd '${_instdir}/bin'; ./astrodmx_capture -D2; popd\"" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ echo "alias astrodmx=\"pushd '${_instdir}/bin'; ./launcher.sh; popd\"" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
}