summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Roll2020-10-18 11:59:27 +1000
committerAshley Roll2020-10-18 11:59:27 +1000
commitff5036e91582dbf7ff0246a240d8dafa21e7372a (patch)
tree007dda30af4c03cc7acfba6fc46ee7cac6829fe1
parent866970aaf8a81294e1f2c6c9e0fdfb82a6550860 (diff)
downloadaur-ff5036e91582dbf7ff0246a240d8dafa21e7372a.tar.gz
Updated to version 0.78.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eadb2403c979..bcf05d41da32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = astrodmx-capture
pkgdesc = AstroDMx Capture Astronomical Imaging
- pkgver = 0.78.3
+ pkgver = 0.78.5
pkgrel = 1
url = https://www.linux-astro-imaging.uk/
install = astrodmx-capture.install
arch = x86_64
license = custom
options = !strip
- source = https://www.linux-astro-imaging.uk/sites/downloads/astrodmx_capture-0.78.3-manual-x86_64.tar.gz
- sha256sums = a4bd110c6fb0b7371491ed3d615894edf8ddf927723bad8e2fe497fc8c748184
+ source = https://www.linux-astro-imaging.uk/sites/downloads/linux/dmx/astrodmx-generic-glibc-2.29_0.78.5_x86-64-manual.tar.gz
+ sha256sums = 94de032d90bbad7fec3f4c7315c60d8c876e83fe1b44f12f36432c43334f47b1
pkgname = astrodmx-capture
diff --git a/PKGBUILD b/PKGBUILD
index 3a91e1016f3d..af5a4fede5a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ashely Roll <ash at digitalnemesis dot com>
pkgname=astrodmx-capture
-pkgver=0.78.3
+pkgver=0.78.5
pkgrel=1
pkgdesc="AstroDMx Capture Astronomical Imaging"
arch=('x86_64')
@@ -12,29 +12,29 @@ license=(custom)
options=(!strip)
install=$pkgname.install
-source=("https://www.linux-astro-imaging.uk/sites/downloads/astrodmx_capture-${pkgver}-manual-x86_64.tar.gz")
-sha256sums=("a4bd110c6fb0b7371491ed3d615894edf8ddf927723bad8e2fe497fc8c748184")
+source=("https://www.linux-astro-imaging.uk/sites/downloads/linux/dmx/astrodmx-generic-glibc-2.29_${pkgver}_x86-64-manual.tar.gz")
+sha256sums=("94de032d90bbad7fec3f4c7315c60d8c876e83fe1b44f12f36432c43334f47b1")
_instdir="/usr/local/AstroDMx_Capture"
-_prefix="x86-64-2.29"
+_prefix="R-Linux-64-2.29-generic"
package() {
- # create the desitination folder
- mkdir -p "${pkgdir}${_instdir}"
+ # create the desitination folder
+ mkdir -p "${pkgdir}${_instdir}"
- # copy over the linux 64 bit files
- cp --recursive ${_prefix}/usr/local/AstroDMx_Capture/* "${pkgdir}${_instdir}"
+ # copy over the linux 64 bit files
+ cp --recursive ${_prefix}/usr/local/AstroDMx_Capture/* "${pkgdir}${_instdir}"
# copy over the udev rules
mkdir -p "${pkgdir}/etc/udev/rules.d"
cp ${_prefix}/etc/udev/rules.d/* "${pkgdir}/etc/udev/rules.d"
- # create a profile file to add an alias for astrodmx
+ # create a profile file to add an alias for astrodmx
# this is needed because the application has to be launced from the bin folder
# to correctly work, so we can't just add the path. sigh.
# Update V0.78.3: Now have to start with launcher.sh, this does a cd, so will continue
# to wrap with pushd/popd to not mess up local path
- mkdir -p "${pkgdir}/etc/profile.d"
- echo "alias astrodmx=\"pushd '${_instdir}/bin'; ./launcher.sh; popd\"" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ mkdir -p "${pkgdir}/etc/profile.d"
+ echo "alias astrodmx=\"pushd '${_instdir}/bin'; ./launcher.sh; popd\"" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
}