summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Dallilar2017-04-25 08:20:49 -0400
committerYigit Dallilar2017-04-25 08:20:49 -0400
commitbf69fb22bec5f02bef107cc5edcfd8fc2c287988 (patch)
tree1fa30ec635b9f0f268d5a129db585c00eb438018
downloadaur-bf69fb22bec5f02bef107cc5edcfd8fc2c287988.tar.gz
init repo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f5e19f7612b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = astromatic-psfex
+ pkgdesc = extracts models of the PSF from FITS images processed with sextractor
+ pkgver = 3.17.1
+ pkgrel = 1
+ url = http://www.astromatic.net/software/psfex
+ arch = x86_64
+ license = GPL
+ depends = fftw
+ depends = atlas-lapack
+ depends = astromatic-sextractor
+ source = http://www.astromatic.net/download/psfex/psfex-3.17.1.tar.gz
+ sha1sums = 366a7bdb2609fd0453d712aab3d11fdf95604c60
+
+pkgname = astromatic-psfex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c8024262478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
+
+pkgname=astromatic-psfex
+_pkgname=psfex
+pkgver=3.17.1
+pkgrel=1
+pkgdesc="extracts models of the PSF from FITS images processed with sextractor"
+url="http://www.astromatic.net/software/psfex"
+arch=('x86_64')
+license=('GPL')
+depends=('fftw' 'atlas-lapack' 'astromatic-sextractor')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=(http://www.astromatic.net/download/psfex/psfex-${pkgver}.tar.gz)
+sha1sums=('366a7bdb2609fd0453d712aab3d11fdf95604c60')
+
+build() {
+ cd $srcdir/${_pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+