summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Dallilar2019-03-01 11:49:28 -0500
committerYigit Dallilar2019-03-01 11:49:28 -0500
commitbe24f5c4d457cf5223f9e3f4ee5f8103e6b18ad7 (patch)
tree7a0c9867cefadcaa9d188dbb3bf2cd9d2e79db7f
parent7515259dccfb1e43fa67e728f67c2495b8ce76b8 (diff)
downloadaur-be24f5c4d457cf5223f9e3f4ee5f8103e6b18ad7.tar.gz
compile with openblas-lapack
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD46
2 files changed, 6 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4c9d8af4dae..0f9b253de395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = astromatic-sextractor
pkgdesc = builds a catalogue of objects from an astronomical image (build from source)
pkgver = 2.25.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.astromatic.net/software/sextractor
arch = x86_64
license = GPL
depends = fftw
- depends = blas
- depends = cblas
- depends = lapack
+ depends = openblas-lapack
conflicts = sextractor-bin
replaces = sextractor-bin
source = https://github.com/astromatic/sextractor/archive/2.25.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index fcf3a655c6d0..13ca1497ceb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
-# Note: you need to install either atlas-lapack or openblas-lapack
+# Set it to compile with openblas-lapack
pkgname=astromatic-sextractor
_pkgname=sextractor
pkgver=2.25.0
-pkgrel=2
+pkgrel=3
pkgdesc="builds a catalogue of objects from an astronomical image (build from source) "
url="http://www.astromatic.net/software/sextractor"
arch=('x86_64')
license=('GPL')
-depends=('fftw' 'blas' 'cblas' 'lapack')
+depends=('fftw' 'openblas-lapack')
makedepends=()
provides=()
conflicts=('sextractor-bin')
@@ -18,48 +18,10 @@ backup=()
source=(https://github.com/astromatic/sextractor/archive/${pkgver}.tar.gz)
sha1sums=('3ed53d55c0c77cd98a38bff1bde1b0d6fc625c18')
-_use_mkl=0 # If you want to compile against intel mkl, make the value other than 0.
-
-# decide which library to compile against
-configure_options() {
-
- # First try intel-mkl if _use_mkl switch is on.
- if [ "$_use_mkl" != 0 ]; then
- _MKL=`pacman -Qq intel-mkl 2>/dev/null` || true
- if [ "$_MKL" != "" ]; then
- _COPTS="--enable-mkl"
- else
- echo "_use_mkl=1 but can not locate mkl libraries"
- exit 1
- fi
- echo "Compiling against intel-mkl"
- return
- fi
-
- # Try atlas-lapack first
- _ATLAS=`pacman -Qq atlas-lapack 2>/dev/null` || true
- if [ "$_ATLAS" != "" ]; then
- _COPTS=""
- echo "Compiling against atlas-lapack"
- return
- fi
-
- # If atlas-lapack not installed, fall back to openblas-lapack
- _OBLAS=`pacman -Qq openblas-lapack 2>/dev/null` || true
- if [ "$_OBLAS" != "" ]; then
- _COPTS="--enable-openblas --with-openblas-incdir=/usr/include"
- echo "Compiling against openblas-lapack"
- return
- fi
-
- # If all fails exit and throw error.
- echo "Failed to locate appropriate library: atlas-lapack, openblas-lapack, intel-mkl"
- exit 1
-}
build() {
- configure_options
+ _COPTS="--enable-openblas --with-openblas-incdir=/usr/include"
cd $srcdir/${_pkgname}-${pkgver}
sh autogen.sh