summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2015-07-27 19:34:51 +0200
committerQuan Guo2015-07-27 19:34:51 +0200
commitdbeab176a320b2e3f886067626f75ae00fab935d (patch)
tree163ee7706f005a320df65baf3c0c48d29c097eea
downloadaur-dbeab176a320b2e3f886067626f75ae00fab935d.tar.gz
inital import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b043f3286de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = astroml-examples-git
+ pkgdesc = AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib. This package includes the exmaples shipped with the github version of astroML
+ pkgver = 2015.07.15.gb9e783d
+ pkgrel = 1
+ url = http://www.astroml.org/
+ arch = any
+ license = BSD-3-Clause
+ optdepends = python-astroml
+ optdepends = python2-astroml
+ conflicts = astroml-examples
+ source = git+https://github.com/astroML/astroML.git
+ md5sums = SKIP
+
+pkgname = astroml-examples-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65239baf5854
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=astroml-examples-git
+_gitname=astroML
+pkgver=2015.07.15.gb9e783d
+pkgrel=1
+
+
+pkgdesc="AstroML is a Python module for machine learning and data mining built
+on numpy, scipy, scikit-learn, and matplotlib. This package includes the
+exmaples shipped with the github version of astroML"
+
+url='http://www.astroml.org/'
+arch=('any')
+license=('BSD-3-Clause')
+
+depends=()
+
+optdepends=('python-astroml' 'python2-astroml')
+
+source=("git+https://github.com/astroML/astroML.git")
+
+conflicts=('astroml-examples' )
+
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+package() {
+
+ cd "${srcdir}/${_gitname}"
+
+ install -dm755 ${pkgdir}/usr/share/astroML/examples/{algorithms,datasets,learning}
+ install -D -m644 examples/algorithms/* \
+ ${pkgdir}/usr/share/astroML/examples/algorithms
+ install -D -m644 examples/datasets/* \
+ ${pkgdir}/usr/share/astroML/examples/datasets
+ install -D -m644 examples/learning/* \
+ ${pkgdir}/usr/share/astroML/examples/learning
+ install -D -m644 examples/README.rst ${pkgdir}/usr/share/astroML/examples
+
+}
+