summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorByron Torres2023-12-26 03:16:26 +0000
committerByron Torres2023-12-26 03:17:29 +0000
commit2ccca9acc0187cd85af43f2f311d4ff270080603 (patch)
treea7bcc9e951c77e65ad410c8616d77be68832628a
parent307b2cb81c25d0635da9b3c003e26afa2df2a03f (diff)
downloadaur-2ccca9acc0187cd85af43f2f311d4ff270080603.tar.gz
version 0.1.2.r1.g3f41b58; various fixes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1a47c1e000d..93316d6006ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = astronaut-git
pkgdesc = Gemini browser for the terminal
- pkgver = 0.1.0.r2.g762f8a6
+ pkgver = 0.1.2.r1.g3f41b58
pkgrel = 1
- url = https://git.sr.ht/~adnano/astronaut
+ url = https://sr.ht/~adnano/astronaut
arch = x86_64
license = GPL3
makedepends = git
@@ -10,7 +10,7 @@ pkgbase = astronaut-git
makedepends = scdoc
depends = glibc
options = !lto
- source = astronaut-git::git+https://git.sr.ht/~adnano/astronaut
+ source = astronaut-git::git+https://git.sr.ht/~adnano/astronaut#branch=master
source = Makefile.patch
sha256sums = SKIP
sha256sums = 8e1d4bb411d3d678a9feb4bcfc53954279ebe0fb4c3a4583a3b7a541c05edcd2
diff --git a/PKGBUILD b/PKGBUILD
index e1c2e7f2497f..812f769b4142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Byron Torres <b at torresjrjr dot com>
pkgname=astronaut-git
-pkgver=0.1.0.r2.g762f8a6
+pkgver=0.1.2.r1.g3f41b58
pkgrel=1
pkgdesc="Gemini browser for the terminal"
arch=('x86_64')
-url="https://git.sr.ht/~adnano/astronaut"
+url="https://sr.ht/~adnano/astronaut"
license=('GPL3')
depends=('glibc')
makedepends=('git' 'go' 'scdoc')
options=('!lto')
source=(
- "$pkgname::git+$url"
- 'Makefile.patch')
-sha256sums=('SKIP'
- '8e1d4bb411d3d678a9feb4bcfc53954279ebe0fb4c3a4583a3b7a541c05edcd2')
+ "$pkgname::git+https://git.sr.ht/~adnano/astronaut#branch=master"
+ 'Makefile.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '8e1d4bb411d3d678a9feb4bcfc53954279ebe0fb4c3a4583a3b7a541c05edcd2'
+)
pkgver() {
git -C "$pkgname" describe --long --tags | sed 's/-/.r/;s/-/./'
@@ -22,7 +25,6 @@ pkgver() {
prepare() {
cd "$pkgname"
- patch -p1 < "$srcdir/Makefile.patch"
go mod tidy
}
@@ -34,11 +36,10 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
cd "$pkgname"
- ./configure --prefix=/usr
make
}
package() {
cd "$pkgname"
- make DESTDIR="$pkgdir/" install
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
}