summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-15 23:35:22 -0500
committerLuis Martinez2021-08-15 23:39:18 -0500
commit71b4c86180249e4719c352c73a2e020ab81073af (patch)
tree9af9e7546ae53fb29d30fcbb05c6199796c09f67
downloadaur-71b4c86180249e4719c352c73a2e020ab81073af.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1561817e1bee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = astronaut-git
+ pkgdesc = A Gemini browser for the terminal
+ pkgver = r315.bf35dae
+ pkgrel = 1
+ url = https://git.sr.ht/~adnano/astronaut
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ makedepends = scdoc
+ depends = glibc
+ source = astronaut-git::git+https://git.sr.ht/~adnano/astronaut
+ sha256sums = SKIP
+
+pkgname = astronaut-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f315e69c569
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=astronaut-git
+pkgver=r319.28d3aac
+pkgrel=1
+pkgdesc="A Gemini browser for the terminal"
+arch=('x86_64')
+url="https://git.sr.ht/~adnano/astronaut"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git' 'go' 'scdoc')
+install=
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ sed -i '/-ldflags/d' Makefile
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}