summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroncia2022-01-04 15:29:46 +0300
committerAstroncia2022-01-04 15:29:46 +0300
commit96b4bddb44cf73666708af210c1a92d91b5a0b3a (patch)
tree67eabd34f7dd05d69b2a5a08f542ed459a7212c9
downloadaur-96b4bddb44cf73666708af210c1a92d91b5a0b3a.tar.gz
Upstream 0.0.87
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10230ee4252f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = astronciaiptv-git
+ pkgdesc = IPTV player with EPG support
+ pkgver = 0.0.87
+ pkgrel = 1
+ url = https://gitlab.com/astroncia/iptv
+ arch = any
+ license = GPL3
+ makedepends = make
+ makedepends = git
+ depends = python
+ depends = qt6-base
+ depends = mpv
+ depends = python-pyqt6
+ depends = python-pillow
+ depends = python-pandas
+ depends = python-gobject
+ depends = python-pydbus
+ depends = python-unidecode
+ depends = python-requests
+ depends = python-chardet
+ depends = python-setproctitle
+ depends = ffmpeg
+ optdepends = yt-dlp: YouTube channel support
+ provides = astronciaiptv
+ conflicts = astronciaiptv
+ source = git+https://gitlab.com/astroncia/iptv.git
+ b2sums = SKIP
+
+pkgname = astronciaiptv-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..654122359f1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Astroncia <kestraly+gmail+com>
+
+pkgname=astronciaiptv-git
+pkgver=0.0.87
+pkgrel=1
+pkgdesc="IPTV player with EPG support"
+arch=('any')
+url="https://gitlab.com/astroncia/iptv"
+license=('GPL3')
+depends=('python' 'qt6-base' 'mpv' 'python-pyqt6' 'python-pillow' 'python-pandas' 'python-gobject' 'python-pydbus' 'python-unidecode' 'python-requests' 'python-chardet' 'python-setproctitle' 'ffmpeg')
+optdepends=('yt-dlp: YouTube channel support')
+makedepends=('make' 'git')
+provides=('astronciaiptv')
+conflicts=('astronciaiptv')
+source=("git+${url}.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd iptv
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd iptv
+ sed -i "s/__DEB_VERSION__/${pkgver}/g" usr/lib/astronciaiptv/astroncia_iptv.py
+}
+
+build() {
+ cd iptv
+ make
+}
+
+package() {
+ cd iptv
+ install -D -t "${pkgdir}"/usr/bin usr/bin/astronciaiptv
+ install -Dm644 -t "${pkgdir}"/usr/lib/astronciaiptv usr/lib/astronciaiptv/astroncia_iptv.py
+ install -Dm644 -t "${pkgdir}"/usr/share/applications usr/share/applications/astronciaiptv.desktop
+ install -Dm644 -t "${pkgdir}"/usr/share/astronciaiptv/icons usr/share/astronciaiptv/icons/*.{gif,png}
+ install -Dm644 -t "${pkgdir}"/usr/share/astronciaiptv/icons_dark usr/share/astronciaiptv/icons_dark/*.{gif,png}
+ install -Dm644 -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps usr/share/icons/hicolor/scalable/apps/astronciaiptv.svg
+ install -Dm644 -t "${pkgdir}"/usr/share/metainfo usr/share/metainfo/astronciaiptv.appdata.xml
+ cp -a usr/lib/astronciaiptv/astroncia "${pkgdir}"/usr/lib/astronciaiptv/astroncia
+ cp -a usr/lib/astronciaiptv/thirdparty "${pkgdir}"/usr/lib/astronciaiptv/thirdparty
+
+ # Translations
+ cp -a usr/share/locale "${pkgdir}"/usr/share/locale
+}