summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-10-12 15:22:50 +0200
committerbegin-theadventure2023-10-12 15:22:50 +0200
commit39b5159e12152e3a2c2fdb3cdab8fca14bdba22f (patch)
tree066971b4d48adb0487f210a436fd78bd2227ea73
downloadaur-39b5159e12152e3a2c2fdb3cdab8fca14bdba22f.tar.gz
1.0.10
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13dd25e364eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = astronum
+ pkgdesc = Program for simple astrological and numerological calculations
+ pkgver = 1.0.10
+ pkgrel = 1
+ url = https://github.com/alexkdeveloper/astronum
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = libadwaita
+ source = git+https://github.com/alexkdeveloper/astronum.git#tag=1.0.10
+ sha256sums = SKIP
+
+pkgname = astronum
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54ef184441da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=astronum
+pkgver=1.0.10
+pkgrel=1
+pkgdesc='Program for simple astrological and numerological calculations'
+url="https://github.com/alexkdeveloper/astronum"
+arch=('x86_64' 'aarch64')
+license=('GPL3')
+depends=('libadwaita')
+makedepends=('git' 'meson' 'vala')
+checkdepends=('appstream-glib')
+source=("git+$url.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ ln -s com.github.alexkdeveloper.$pkgname "$pkgdir/usr/bin/$pkgname"
+}