summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroFloyd2015-07-27 18:30:58 +0200
committerAstroFloyd2015-07-27 18:30:58 +0200
commit2e0c59b4cadff047ba089a90004cf5a71b2cde61 (patch)
tree02176eb19f82b71faefd713b22b7b3dbf5235640
downloadaur-2e0c59b4cadff047ba089a90004cf5a71b2cde61.tar.gz
Initial commit: v0.0.1-2
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog10
-rw-r--r--PKGBUILD25
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46cf6a99d536
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = astrotools
+ pkgdesc = Command-line tools for astronomy and astrophysics
+ pkgver = 0.0.1
+ pkgrel = 2
+ url = http://astrotools.sourceforge.net/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc-fortran
+ depends = libsufr
+ depends = libthesky
+ source = http://sourceforge.net/projects/astrotools/files/astrotools-0.0.1.tar.gz
+ sha512sums = 150903efa945ea68baf4f62419d5d2e21dcc2db9f675267482717daa99b9485dfc65f3d9e3dadb6965abc903bbe2cc7099f1c6c51d5974e623dad0b1419eaa47
+
+pkgname = astrotools
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..5d8749e563cc
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,10 @@
+
+ChangeLog for astroTools PKGBUILD
+http://astrotools.sourceforge.net/
+
+* astroTools-0.0.1-2 (2015-04-28 - AstroFloyd)
+ Added cmake as a make dependency
+
+* astroTools-0.0.1-1 (2015-04-26 - AstroFloyd)
+ Initial PKGBUILD for astroTools, to be uploaded to AUR
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d15e65a735fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: AstroFloyd < AstroFloyd [at] gmail [dt] com >
+pkgname=astrotools
+pkgver=0.0.1
+pkgrel=2
+pkgdesc="Command-line tools for astronomy and astrophysics"
+arch=('i686' 'x86_64')
+url="http://astrotools.sourceforge.net/"
+license=('GPL3')
+depends=('libsufr' 'libthesky')
+makedepends=('cmake' 'gcc-fortran')
+changelog=ChangeLog
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver.tar.gz")
+sha512sums=('150903efa945ea68baf4f62419d5d2e21dcc2db9f675267482717daa99b9485dfc65f3d9e3dadb6965abc903bbe2cc7099f1c6c51d5974e623dad0b1419eaa47')
+
+build() {
+ mkdir -p "$pkgname-$pkgver"/build
+ cd "$pkgname-$pkgver"/build/
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr/" ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"/build/
+ make install
+}