summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Vladovic2022-02-18 03:19:44 +0000
committerDario Vladovic2022-02-18 03:19:44 +0000
commitc932eabc897dd3352561099b5b93127f4957d12b (patch)
tree01c8a9dcce1ef6965b8f3bf93c55ecc7d4f58393
downloadaur-c932eabc897dd3352561099b5b93127f4957d12b.tar.gz
create asuka 0.8.3 package
-rw-r--r--.SRCINFO17
-rw-r--r--.editorconfig10
-rw-r--r--PKGBUILD29
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf04ea032922
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = asuka
+ pkgdesc = Gemini Project client written in Rust with NCurses
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://sr.ht/~julienxx/Asuka
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = pkg-config
+ depends = gcc-libs
+ depends = zlib
+ depends = openssl
+ depends = ncurses
+ source = asuka-0.8.3.tar.gz::https://git.sr.ht/~julienxx/asuka/archive/0.8.3.tar.gz
+ sha256sums = 1305d65e07e83fe33ca102637fa27f8dafae9a9aaa436414c29532c4ed51c6ea
+
+pkgname = asuka
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..ebb5a5e8de7b
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,10 @@
+# editorconfig.org
+root = true
+
+[PKGBUILD]
+charset = utf-8
+indent_style = space
+end_of_line = lf
+trim_trailing_whitespace = true
+insert_final_newline = true
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d1064fdc87d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dario Vladovic <d.vladimyr@gmail.com>
+pkgname=asuka
+pkgver=0.8.3
+pkgrel=1
+pkgdesc='Gemini Project client written in Rust with NCurses'
+arch=('x86_64')
+url=https://sr.ht/~julienxx/Asuka
+license=('MIT')
+depends=('gcc-libs' 'zlib' 'openssl' 'ncurses')
+makedepends=('rust' 'pkg-config')
+source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~julienxx/asuka/archive/$pkgver.tar.gz")
+sha256sums=('1305d65e07e83fe33ca102637fa27f8dafae9a9aaa436414c29532c4ed51c6ea')
+
+prepare() {
+ cd $pkgname-$pkgver
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release --frozen
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 target/release/asuka "$pkgdir/usr/bin/asuka"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+