summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2022-12-04 18:52:32 +0100
committerFabian Bornschein2022-12-04 18:52:32 +0100
commit0d4f662e54cbfa34ea1b6f63f69afa809963daee (patch)
treee8fe3e58069b550fcc764f40d40c2c3fadc84206
parent0acf359df1764f6f8998301cebe645dd73145704 (diff)
downloadaur-0d4f662e54cbfa34ea1b6f63f69afa809963daee.tar.gz
remove asusd-nohwdep.service again to provide the vanilla configuration
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--asusctl.install6
-rw-r--r--asusd-nohwdep.service20
4 files changed, 4 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70f1d5f74554..6bc7c00ccab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asusctl
pkgdesc = A control daemon, tools, and a collection of crates for interacting with ASUS ROG laptops
pkgver = 4.5.2
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/asus-linux/asusctl
arch = x86_64
license = MPL2
@@ -19,9 +19,7 @@ pkgbase = asusctl
makedepends = systemd
conflicts = asusctl-git
source = git+https://gitlab.com/asus-linux/asusctl.git#commit=14bf07ba79ae86103d1caf06cd09c36e78b5a8e2
- source = asusd-nohwdep.service
sha256sums = SKIP
- sha256sums = f6cf6fe6e379f29282c503351cf7e09c5141572c9acc183b934764099958e4d2
pkgname = asusctl
pkgdesc = A control daemon, CLI tools, and a collection of crates for interacting with ASUS ROG laptops
diff --git a/PKGBUILD b/PKGBUILD
index a37319d24330..98148a1e3437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=asusctl
pkgname=(asusctl rog-control-center)
pkgver=4.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="A control daemon, tools, and a collection of crates for interacting with ASUS ROG laptops"
arch=('x86_64')
url="https://gitlab.com/asus-linux/asusctl"
@@ -14,10 +14,8 @@ makedepends=('cmake' 'git' 'rust'
'libusb' 'power-profiles-daemon' 'supergfxctl' 'systemd')
conflicts=('asusctl-git')
_commit=14bf07ba79ae86103d1caf06cd09c36e78b5a8e2 # tags/4.5.2^0
-source=("git+${url}.git#commit=$_commit"
- "asusd-nohwdep.service")
-sha256sums=('SKIP'
- 'f6cf6fe6e379f29282c503351cf7e09c5141572c9acc183b934764099958e4d2')
+source=("git+${url}.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgbase}"
@@ -55,9 +53,6 @@ package_asusctl() {
cd "${pkgbase}"
make DESTDIR="${pkgdir}" install
- install -Dm 644 "${srcdir}/asusd-nohwdep.service" \
- -t "${pkgdir}/usr/lib/systemd/system"
-
_pick rogcc "${pkgdir}/usr/bin/rog-control-center" \
"${pkgdir}/usr/share/applications/rog-control-center.desktop" \
"${pkgdir}/usr/share/icons/hicolor/512x512/apps/rog-control-center.png" \
diff --git a/asusctl.install b/asusctl.install
index 5805afd01d24..c1406eaefc2e 100644
--- a/asusctl.install
+++ b/asusctl.install
@@ -5,11 +5,5 @@ post_upgrade() {
systemctl daemon-reload
systemctl restart asusd.service
fi
- if [ $(systemctl is-active asusd-nohwdep.service) == "active" ]
- then
- printf ":: asusd is running, and requires a restart of the serviceā€¦\n"
- systemctl daemon-reload
- systemctl restart asusd-nohwdep.service
- fi
}
diff --git a/asusd-nohwdep.service b/asusd-nohwdep.service
deleted file mode 100644
index 477be2e065b4..000000000000
--- a/asusd-nohwdep.service
+++ /dev/null
@@ -1,20 +0,0 @@
-[Unit]
-Description=ASUS Notebook Control
-StartLimitInterval=200
-StartLimitBurst=2
-Before=multi-user.target
-Conflicts=asusd.service
-
-[Service]
-Environment=IS_SERVICE=1
-ExecStartPre=/bin/sleep 2
-ExecStart=/usr/bin/asusd
-Restart=on-failure
-Restart=always
-RestartSec=1
-Type=dbus
-BusName=org.asuslinux.Daemon
-SELinuxContext=system_u:system_r:unconfined_t:s0
-
-[Install]
-WantedBy=multi-user.target