summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2021-09-18 13:00:11 +0200
committerFabian Bornschein2021-09-18 13:00:11 +0200
commit91ca8c40092c956a54ed93bc093472ad6c34c461 (patch)
tree6e184d95d2911eef41e0707777da27d32d357bd5
downloadaur-91ca8c40092c956a54ed93bc093472ad6c34c461.tar.gz
"...not all stories have happy endings; but that doesn't mean they're not worth the read." -- Cassia Leo
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d887303b24aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = asusctl
+ pkgdesc = Asus hardware control utilities
+ pkgver = 4.0.3
+ pkgrel = 1
+ url = https://gitlab.com/asus-linux/asusctl
+ arch = x86_64
+ license = MPL2
+ makedepends = git
+ makedepends = rust
+ depends = libusb
+ depends = systemd
+ depends = power-profiles-daemon
+ optdepends = acpi_call: fan control
+ conflicts = asusctl-git
+ source = git+https://gitlab.com/asus-linux/asusctl.git#commit=812f9ea30ea0156a081927f9e534e572c9cedf0d
+ sha256sums = SKIP
+
+pkgname = asusctl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30e2c3e4aaee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Fabian Bornschein <fabiscafe-cat-mailbox-dog-com>
+# Contributor: Static_Rocket
+
+pkgname=asusctl
+pkgver=4.0.3
+pkgrel=1
+pkgdesc="Asus hardware control utilities"
+arch=('x86_64')
+url="https://gitlab.com/asus-linux/asusctl"
+license=('MPL2')
+depends=('libusb' 'systemd' 'power-profiles-daemon')
+optdepends=('acpi_call: fan control')
+makedepends=('git' 'rust')
+conflicts=('asusctl-git')
+_commit=812f9ea30ea0156a081927f9e534e572c9cedf0d # tags/4.0.3^0
+source=("git+${url}.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd "${pkgname}"
+ make build
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}