summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Riedel2022-02-18 04:21:01 +0100
committerSebastian Riedel2022-02-18 04:21:01 +0100
commit6c54d7ec4d9cf9c1f32a22711bb9669e89ecb054 (patch)
treee54073a520e8a4432b02901661916e352eac5a83
downloadaur-6c54d7ec4d9cf9c1f32a22711bb9669e89ecb054.tar.gz
Version 5.40
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD32
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..885226a1c723
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = asxxxx
+ pkgdesc = ASxxxx Cross Assemblers
+ pkgver = 5.40
+ pkgrel = 1
+ url = https://shop-pdp.net/ashtml/asxxxx.php
+ arch = x86_64
+ license = GPL3
+ makedepends = unzip
+ noextract = asxs5p40.zip
+ source = https://shop-pdp.net/_ftp/asxxxx/asxs5p40.zip
+ sha256sums = ac8277b85308b9fdc3e27c50557cc3ba45fe0de85ddc96c936fb25e5fd3a3e22
+
+pkgname = asxxxx
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ea1bad4556b6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.zip
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b307c4b374a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: basxto <archlinux basxto de>
+pkgname='asxxxx'
+pkgver=5.40
+pkgrel=1
+pkgdesc='ASxxxx Cross Assemblers'
+url='https://shop-pdp.net/ashtml/asxxxx.php'
+license=('GPL3')
+arch=('x86_64')
+makedepends=('unzip')
+source=("https://shop-pdp.net/_ftp/asxxxx/asxs$(echo $pkgver|tr . p).zip")
+noextract=("asxs$(echo $pkgver|tr . p).zip")
+sha256sums=('ac8277b85308b9fdc3e27c50557cc3ba45fe0de85ddc96c936fb25e5fd3a3e22')
+
+prepare() {
+ # convert to unix as described in readme
+ unzip -L -a -f ${noextract[0]}
+}
+
+build() {
+ cd "${srcdir}/asxv$(echo $pkgver | fold -w1 | head -n 1)pxx/asxmak/linux/build/"
+ make
+}
+
+
+package() {
+ cd "${srcdir}/asxv$(echo $pkgver | fold -w1 | head -n 1)pxx/"
+ install -d "${pkgdir}/usr/bin/"
+ install -Dm755 asxmak/linux/exe/as* asxmak/linux/exe/s19os9 "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/${pkgname}/asxhtml/"
+ install -Dm644 asxhtml/* "${pkgdir}/usr/share/${pkgname}/asxhtml/"
+ install -Dm644 readme.txt changes.txt "${pkgdir}/usr/share/${pkgname}/"
+}