summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsashok7242020-10-07 12:32:38 +0300
committersashok7242020-10-07 12:32:38 +0300
commitd5fb572d7a86ca543d5b510a480eccc220837eae (patch)
tree11f27b94bcaeb66be6bc03d82212088ff5c7ba45
downloadaur-d5fb572d7a86ca543d5b510a480eccc220837eae.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89c770559f21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = async-profiler-git
+ pkgdesc = Sampling CPU and HEAP profiler for Java featuring AsyncGetCallTrace + perf_events
+ pkgver = r386.4b5a17b
+ pkgrel = 1
+ url = https://github.com/jvm-profiling-tools/async-profiler
+ arch = x86_64
+ groups = jvm-profiling-tools
+ license = Apache
+ depends = java-environment
+ provides = async-profiler
+ conflicts = async-profiler
+ source = git+https://github.com/jvm-profiling-tools/async-profiler
+ sha256sums = SKIP
+
+pkgname = async-profiler-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a37edd2555a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: sashok724 <archlinux at sashok724 dot net>
+
+_pkgname=async-profiler
+pkgname=async-profiler-git
+pkgver=r386.4b5a17b
+pkgrel=1
+pkgdesc='Sampling CPU and HEAP profiler for Java featuring AsyncGetCallTrace + perf_events'
+arch=('x86_64')
+url='https://github.com/jvm-profiling-tools/async-profiler'
+license=('Apache')
+provides=('async-profiler')
+conflicts=('async-profiler')
+groups=('jvm-profiling-tools')
+depends=('java-environment')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ make all
+}
+
+package() {
+ cd $_pkgname
+
+ install -d "$pkgdir/usr/bin/"
+ install -d "$pkgdir/opt/async-profiler/build/"
+
+ install -m644 "build/libasyncProfiler.so" "build/async-profiler.jar" "$pkgdir/opt/async-profiler/build/"
+ install build/jattach "$pkgdir/opt/async-profiler/build/"
+ install profiler.sh "$pkgdir/opt/async-profiler/"
+ ln -s "$pkgdir/opt/async-profiler/profiler.sh" "$pkgdir/usr/bin/async-profiler"
+}