summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-02 16:36:30 -0500
committerVincent Grande2021-01-02 16:36:30 -0500
commit11387d5856268a065793f18d1dbcf0e4b25641d7 (patch)
tree28f18581115534db680cece071fd6ffa2bfd835c
downloadaur-11387d5856268a065793f18d1dbcf0e4b25641d7.tar.gz
fix
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD46
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31d79787d656
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = at-spi2-core-minimal-git
+ pkgdesc = Protocol definitions and daemon for D-Bus at-spi
+ pkgver = 2.38.0
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/at-spi2-core
+ arch = x86_64
+ license = GPL2
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ depends = dbus
+ depends = glib2
+ depends = libxtst
+ optdepends = dbus-broker: Alternative bus implementation
+ provides = at-spi2-core
+ conflicts = at-spi2-core
+ source = git+https://gitlab.gnome.org/GNOME/at-spi2-core.git
+ sha256sums = SKIP
+
+pkgname = at-spi2-core-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cc0cee7136e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=at-spi2-core-minimal-git
+pkgver=2.38.0
+pkgrel=1
+pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
+url="https://gitlab.gnome.org/GNOME/at-spi2-core"
+arch=(x86_64)
+license=(GPL2)
+depends=(dbus glib2 libxtst)
+makedepends=(gobject-introspection git meson)
+optdepends=('dbus-broker: Alternative bus implementation')
+provides=(at-spi2-core)
+conflicts=(at-spi2-core)
+source=("git+https://gitlab.gnome.org/GNOME/at-spi2-core.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd at-spi2-core
+ git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd at-spi2-core
+}
+
+build() {
+ arch-meson at-spi2-core build -D docs=false -D default_bus=dbus-daemon
+
+ meson compile -C build
+}
+
+#check() {
+ # memory test fails without desktop
+ # broker fails to launch without journald
+# dbus-run-session meson test -C build --print-errorlogs || :
+# }
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ }
+
+# vim:set ts=2 sw=2 et:
+