summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2020-01-04 13:57:46 +0100
committerOliver Jaksch2020-01-04 13:57:46 +0100
commit258d89966f86619c4a1dccafca1ba9e878a89925 (patch)
tree55857e8e6be4854d1f650eebb542f8f8fca62d3a
parent9ca1ac2dc08fe963b2111a3e9d640746587ad585 (diff)
downloadaur-258d89966f86619c4a1dccafca1ba9e878a89925.tar.gz
Now with .desktop file and icon :)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--atari800.desktop10
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cf4afc86cfa..94f9dd5d62a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = atari800
pkgdesc = An emulator of the Atari 800/800XL/130XE/5200 with various extensions
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://atari800.github.io
arch = i686
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = atari800
depends = sdl
optdepends = libpng: PNG screenshot support
source = https://github.com/atari800/atari800/archive/ATARI800_4_2_0.tar.gz
+ source = atari800.desktop
sha256sums = 0bad99575293742e9e062e9fe9d104fe57228b1a32fec7a033b889edc819d7a4
+ sha256sums = 95e03020358a0855e12ee19b62abebb336e472fcf525f7eb42dcc28419588df9
pkgname = atari800
diff --git a/PKGBUILD b/PKGBUILD
index dfd5bca053aa..8be27ad63082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,17 @@
pkgname=atari800
pkgver=4.2.0
_pkgver=${pkgver//./_}
-pkgrel=1
+pkgrel=2
pkgdesc="An emulator of the Atari 800/800XL/130XE/5200 with various extensions"
arch=('i686' 'x86_64')
url="https://atari800.github.io"
license=('GPL2')
depends=('sdl')
optdepends=('libpng: PNG screenshot support')
-source=("https://github.com/atari800/${pkgname}/archive/ATARI800_${_pkgver}.tar.gz")
-sha256sums=('0bad99575293742e9e062e9fe9d104fe57228b1a32fec7a033b889edc819d7a4')
+source=("https://github.com/atari800/${pkgname}/archive/ATARI800_${_pkgver}.tar.gz"
+ "atari800.desktop")
+sha256sums=('0bad99575293742e9e062e9fe9d104fe57228b1a32fec7a033b889edc819d7a4'
+ '95e03020358a0855e12ee19b62abebb336e472fcf525f7eb42dcc28419588df9')
build() {
cd "${pkgname}-ATARI800_${_pkgver}"
@@ -37,5 +39,7 @@ build() {
package() {
cd "${pkgname}-ATARI800_${_pkgver}"/src
make DESTDIR="${pkgdir}/" install
+ install -Dm755 "${srcdir}/atari800.desktop" "${pkgdir}/usr/share/applications/atari800.desktop"
+ install -Dm755 "../data/atari2.png" "${pkgdir}/usr/share/pixmaps/atari800.png"
msg2 "\e[1;32mThis package has some options you might interested in. Have a look to COPTS at PKGBUILD. \e[0m"
}
diff --git a/atari800.desktop b/atari800.desktop
new file mode 100644
index 000000000000..46331f45319f
--- /dev/null
+++ b/atari800.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Atari800
+GenericName=Atari800 - portable and free Atari 8-bit emulator
+Comment=Atari800 is the emulator of Atari 8-bit computer systems and 5200 game console for Linux [...] and other systems supported by the SDL library. Our main objective is to create a freely distributable portable emulator (i.e. with source code available).
+Exec=atari800
+Icon=atari800
+Terminal=false
+Type=Application
+Categories=Game;Emulator;
+Keywords=Game;Emulator;Arcade;