summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgnubeest2015-07-13 21:09:11 -0500
committergnubeest2015-07-13 21:09:11 -0500
commitbea4b7af817b1eaaae0afc9903d9ef20ea1d089b (patch)
tree38403d9986978c3ad1fd7fc8e50ef90b842c78fd
downloadaur-bea4b7af817b1eaaae0afc9903d9ef20ea1d089b.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rwxr-xr-xPKGBUILD53
-rwxr-xr-xatari800.install18
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3005119657c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = atari800
+ pkgdesc = An emulator of the Atari 800/800XL/130XE/5200 with various extensions
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = http://atari800.sourceforge.net/
+ install = atari800.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL
+ makedepends = unzip
+ depends = libpng
+ depends = sdl
+ optdepends = xboxdrv: XBox/360gamepad driver - supports a multitude of controllers ,like PS3 USB controller
+ optdepends = qtsixa: utility to configure and use sixaxis controller via bluetooth
+ optdepends = jstest-gtk: simple GTK2-based joystick tester and calibrator
+ source = http://downloads.sourceforge.net/sourceforge/atari800/atari800-3.1.0.tar.gz
+ source = http://sourceforge.net/projects/atari800/files/ROM/Original%20XL%20ROM/xf25.zip
+ md5sums = 354f8756a7f33cf5b7a56377d1759e41
+ md5sums = 4dc3b6b4313e9596c4d474785a37b94d
+
+pkgname = atari800
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ac91aa437ada
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Original Contributor: Vinzenz Vietzke <vinz@archlinux.us>
+# Modified by: Farhan Yousasf <farhany@gmail.com>
+# Modified by: c0mmando <c0mmand0_88@yahoo.com.ar>
+# Maintainer: beest <gnubeest@gmail.com>
+
+pkgname=atari800
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="An emulator of the Atari 800/800XL/130XE/5200 with various extensions"
+arch=('i686' 'x86_64' 'armv6h')
+url="http://atari800.sourceforge.net/"
+license=('GPL')
+depends=('libpng' 'sdl')
+optdepends=(
+ 'xboxdrv: XBox/360gamepad driver - supports a multitude of controllers ,like PS3 USB controller'
+ 'qtsixa: utility to configure and use sixaxis controller via bluetooth'
+ 'jstest-gtk: simple GTK2-based joystick tester and calibrator'
+)
+makedepends=('unzip')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz \
+ http://sourceforge.net/projects/atari800/files/ROM/Original%20XL%20ROM/xf25.zip)
+install=atari800.install
+md5sums=('354f8756a7f33cf5b7a56377d1759e41' \
+ '4dc3b6b4313e9596c4d474785a37b94d')
+
+build()
+{
+ # This emulator has a few linux compatible targets. Edit the target
+ # and depends variables if you'd like a different target.
+ # Valid choices are: default , android , falcon , javanvm , javanvm-basic , ps2 , windx , x11
+ # see -> ./configure --target --help
+ #default=autodetect graphics and sound
+ _target=default
+
+ # Pass the reponse to the configure script
+
+ cd ${srcdir}/${pkgname}-${pkgver}/src
+ ./configure --target=${_target} --prefix=/usr
+ make
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}/src
+ make DESTDIR=${pkgdir} install
+
+ # Copy the required ROMs and disks to /usr/share/atari800
+ cd ${srcdir}
+ install -d ${pkgdir}/usr/share/${pkgname}
+ for _n in *.ROM *.XFD *.ATR; do
+ install -m644 ${_n} ${pkgdir}/usr/share/${pkgname}/
+ done
+}
diff --git a/atari800.install b/atari800.install
new file mode 100755
index 000000000000..0743de5fefa5
--- /dev/null
+++ b/atari800.install
@@ -0,0 +1,18 @@
+# Message displayed for a fresh install.
+post_install()
+{
+ # Display a helpful message to the user
+ echo ""
+ echo "***************************************************************"
+ echo " Running Atari800 for the first time will create a config file"
+ echo " at $HOME/.atari800.cfg and immediately open the emulator."
+ echo " Pressing the F1 key will open the menu where you should modify"
+ echo " the emultion configuration ROM path to /usr/share/atari800"
+ echo " to use the included ROMs Atari800 needs for emulation."
+ echo "***************************************************************"
+ echo ""
+}
+
+op=$1
+shift
+$op $* \ No newline at end of file