summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-08-20 14:36:22 +0200
committerFrederic Bezies2021-08-20 14:36:22 +0200
commit51e55a500b5a1ab87dee683ad4dccfcf2b0d06d1 (patch)
tree3085ebc823bf6cbc42f35b992ee5ba08a99a4373
downloadaur-51e55a500b5a1ab87dee683ad4dccfcf2b0d06d1.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD53
-rw-r--r--atari800.desktop10
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02192c040e04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = atari800-git
+ pkgdesc = An emulator of the Atari 800/800XL/130XE/5200 with various extensions - git
+ pkgver = r2731.77a195d1
+ pkgrel = 1
+ url = https://atari800.github.io
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sdl
+ optdepends = libpng: PNG screenshot support
+ conflicts = atari800
+ source = git+https://github.com/atari800/atari800.git
+ source = atari800.desktop
+ sha256sums = SKIP
+ sha256sums = 95e03020358a0855e12ee19b62abebb336e472fcf525f7eb42dcc28419588df9
+
+pkgname = atari800-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1edf777ee74a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Frederic Bezies
+# based on Oliver Jaksch <arch-aur@com-in.de> PKGBUILD for Atari800
+
+pkgname=atari800-git
+_pkgname=atari800
+pkgver=r2731.77a195d1
+_pkgver=${pkgver//./_}
+pkgrel=1
+pkgdesc="An emulator of the Atari 800/800XL/130XE/5200 with various extensions - git"
+arch=('i686' 'x86_64')
+url="https://atari800.github.io"
+license=('GPL2')
+depends=('sdl')
+conflicts=('atari800')
+optdepends=('libpng: PNG screenshot support')
+source=("git+https://github.com/atari800/atari800.git"
+ "atari800.desktop")
+sha256sums=('SKIP'
+ '95e03020358a0855e12ee19b62abebb336e472fcf525f7eb42dcc28419588df9')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "${_pkgname}"
+
+ ./autogen.sh
+
+ # configure default - neccessary
+ COPTS="--prefix=/usr"
+
+ # The R: Network device
+ COPTS="${COPTS} --enable-riodevice"
+
+ # SIO Sound for true retro feeling
+ COPTS="${COPTS} --enable-seriosound"
+
+ # OnScreen Keyboard
+ COPTS="${COPTS} --enable-onscreenkeyboard"
+
+ ./configure ${COPTS}
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm755 "${srcdir}/atari800.desktop" "${pkgdir}/usr/share/applications/atari800.desktop"
+ install -Dm755 "${srcdir}/atari800/data/atari2.png" "${pkgdir}/usr/share/pixmaps/atari800.png"
+}
diff --git a/atari800.desktop b/atari800.desktop
new file mode 100644
index 000000000000..46331f45319f
--- /dev/null
+++ b/atari800.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Atari800
+GenericName=Atari800 - portable and free Atari 8-bit emulator
+Comment=Atari800 is the emulator of Atari 8-bit computer systems and 5200 game console for Linux [...] and other systems supported by the SDL library. Our main objective is to create a freely distributable portable emulator (i.e. with source code available).
+Exec=atari800
+Icon=atari800
+Terminal=false
+Type=Application
+Categories=Game;Emulator;
+Keywords=Game;Emulator;Arcade;