summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Rizzitello2018-01-21 08:54:50 -0500
committerChris Rizzitello2018-01-21 08:54:50 -0500
commit31250324145d88fd4fc1fbee830917311e51ca5e (patch)
treeea6c36cba1d916501cb6cc4404b3303fb15719e0
parent328b71f4348c3ca75b6dc57e4898ebce927ebae6 (diff)
downloadaur-31250324145d88fd4fc1fbee830917311e51ca5e.tar.gz
Release 1.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4eb0cbcb6f6f..95e08d0da717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Nov 5 00:11:48 UTC 2017
+# Sun Jan 21 13:54:28 UTC 2018
pkgbase = atcore
pkgdesc = KDE 3D Printing libary
- pkgver = 0.90.2
+ pkgver = 1.0.0
pkgrel = 1
url = https://www.kde.org/
arch = i686
@@ -12,8 +12,8 @@ pkgbase = atcore
depends = qt5-serialport
depends = qt5-charts
provides = atcore
- source = http://download.kde.org/unstable/atcore/atcore-0.90.2.tar.xz
- sha256sums = 02790ea72435227de42a232155f0f51990a637b724fc244e277ff5fbae2c1fd5
+ source = https://download.kde.org/stable/atcore/1.0.0/atcore-1.0.0.tar.xz
+ sha256sums = ffd12455c9b8db853e455a437d6c6b601e0003c6732bbc6c2828032e004530e2
pkgname = atcore
diff --git a/PKGBUILD b/PKGBUILD
index 6e5c77215ad8..e50c7f3ca0e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=atcore
confilicts=('atcore-git')
provides=('atcore')
-pkgver=0.90.2
+pkgver=1.0.0
pkgrel=1
pkgdesc="KDE 3D Printing libary"
arch=('i686' 'x86_64')
url="https://www.kde.org/"
license=('LGPL2')
-buildDepends=('git' 'cmake' 'extra-cmake-modules')
+buildDepends=('git' 'cmake' 'extra-cmake-modules' 'doxygen')
depends=('qt5-base' 'qt5-serialport' 'qt5-charts' ) #Qt5)
-source=('http://download.kde.org/unstable/atcore/atcore-0.90.2.tar.xz')
-sha256sums=('02790ea72435227de42a232155f0f51990a637b724fc244e277ff5fbae2c1fd5')
+source=('https://download.kde.org/stable/atcore/1.0.0/atcore-1.0.0.tar.xz')
+sha256sums=('ffd12455c9b8db853e455a437d6c6b601e0003c6732bbc6c2828032e004530e2')
build() {
cd "atcore-$pkgver"
- cmake -DCMAKE_INSTALL_PREFIX=$(qtpaths --install-prefix) -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_BUILD_TYPE=Release -DBUILD_TEST_GUI=ON CMakeLists.txt
+ cmake -DCMAKE_INSTALL_PREFIX=$(qtpaths --install-prefix) -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_BUILD_TYPE=Release -DBUILD_TEST_GUI=ON -DBUILD_DOCS=ON CMakeLists.txt
make
}
package(){