summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Rizzitello2017-11-04 20:12:13 -0400
committerChris Rizzitello2017-11-04 20:12:13 -0400
commit328b71f4348c3ca75b6dc57e4898ebce927ebae6 (patch)
treefee08a073b2157047829d069dea6b8a7e70f7dd6
downloadaur-328b71f4348c3ca75b6dc57e4898ebce927ebae6.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4eb0cbcb6f6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Nov 5 00:11:48 UTC 2017
+pkgbase = atcore
+ pkgdesc = KDE 3D Printing libary
+ pkgver = 0.90.2
+ pkgrel = 1
+ url = https://www.kde.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL2
+ depends = qt5-base
+ depends = qt5-serialport
+ depends = qt5-charts
+ provides = atcore
+ source = http://download.kde.org/unstable/atcore/atcore-0.90.2.tar.xz
+ sha256sums = 02790ea72435227de42a232155f0f51990a637b724fc244e277ff5fbae2c1fd5
+
+pkgname = atcore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e5c77215ad8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Chris Rizzitello <sithlord48@gmail.com>
+pkgname=atcore
+confilicts=('atcore-git')
+provides=('atcore')
+pkgver=0.90.2
+pkgrel=1
+pkgdesc="KDE 3D Printing libary"
+arch=('i686' 'x86_64')
+url="https://www.kde.org/"
+license=('LGPL2')
+buildDepends=('git' 'cmake' 'extra-cmake-modules')
+depends=('qt5-base' 'qt5-serialport' 'qt5-charts' ) #Qt5)
+source=('http://download.kde.org/unstable/atcore/atcore-0.90.2.tar.xz')
+sha256sums=('02790ea72435227de42a232155f0f51990a637b724fc244e277ff5fbae2c1fd5')
+
+build() {
+ cd "atcore-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=$(qtpaths --install-prefix) -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_BUILD_TYPE=Release -DBUILD_TEST_GUI=ON CMakeLists.txt
+ make
+}
+package(){
+ cd "atcore-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}